Jump to content
Corsair Community

Vengeance 2000 Device won't Install


Recommended Posts

Hello All,


So lets start at the beginning...


I own both a Vengeance 1500 and Vengeance 2000 Headset. Recently I had to RMA my 2000 leaving me to use the 1500. The 1500 (In Windows 7 x64) Comes up as an unknown device (Plugged into a USB 2.0 Port. Tried Multiple ports). I removed everything Corsair-related and retried, No dice.


Recently I've received the 2000 back. This will no longer install on my system (That is, The .MSI runs, but the device is still unknown). I've tried to

"Force" the driver to install and gotten mixed results: BSOD from the USBAudio.sys file, Device cannot start (error code 10), Device not plugged in.


The device is brand new from Corsair, So I'd assume it isn't a hardware issue.


I've looked for Chipset etc updates from Intel and ANY updates for my motherboard from ASRock.


Anyone have any other ideas before I format and reinstall? >.<

Link to comment
Share on other sites

If possible, Try the dongle on another computer and see if the same issue is there.


The hardware id should have this;USB\VID_1B1C&PID_0A04&MI_00 as that what the drivers have which is probably why you can't install it.


Have you tried reinstalling your chipset drivers? Latest BIOS?

Run SFC /SCANNOW in cmd and see if that helps.

Link to comment
Share on other sites

I forgot to put in my last post - Thanks a bunch for your help!


In response to your possibilities:

The Dongle and Headset work (and 1500 for that matter) work on all my other PCs. Just this one. I've Removed and Reinstalled the Chipset drivers, no dice there


SFC came up clean. No bios changes or updates

Link to comment
Share on other sites

Delete your old USB Devices.


Advanced system settings>Environment variables>New (Under "User Variables")

Variable name: devmgr_show_nonpresent_devices

Variable value: 1


Device Manager>View>Show Hidden Devices>Expand Sound/Audio and right click>uninstall any grey entries.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...