Jump to content
Corsair Community

M65 Problem


Recommended Posts

I just received the mouse yesterday.


I downloaded the software and did the firmware update M65FwUpdate v2.12 sw-v1.23.exe


I restarted my computer etc.




Ever since installing the mouse and plugging it into my computer, my computer will freeze. I've had a deathadder for 5+ years no issues like this whatsoever.


Next, certain applications [i.e. the Feed The Beast Launcher window, it won't let me click on anything inside that box] And when I open up google chrome, everytime I click on a different tab it auto closes the tab, but doesn't do it in any other browser.


Other then the weird clicking problems and auto closing of tabs, the mouse has worked fine.


If there's a new firmware update or I'm doing something wrong, please let me know, I don't want to have to RMA it if possible!



Link to comment
Share on other sites

Have you tried reflashing the firmware?

Latest BIOS and chipset drivers?

Have you tried uninstalling all the previous mouse drivers?

Have you tried reinstalling the drivers? Tried a different USB port?

Try the mouse on another computer and see if the same issues persist.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...