Jump to content
Corsair Community

Trouble getting memory to work


Recommended Posts

Hi everyone,


I have a Gigabyte GA-H55M-S2H motherboard with 2GB of RAM that's powered a very stable home server for a couple years now. Recently I've been trying to upgrade the memory and I'm having lots of trouble. I've tried three different manufacturer's memory and each time the BIOS sees it all but Windows blue-screens within 10 minutes or so.


The most recent attempt is with 2x4GB sticks of Corsair Vengeance LP, model CML8GX3M2A1600C9. The sticker on the memory reads 1600MHz, 9-9-9-24, 1.50v, ver 8.16. This model memory is listed in Corsair's database as being compatible with this motherboard. I've verified that it's running at 1333 speeds (the stock speed for this system), 9-9-9-24, and though it automatically came up at 1T, I manually changed it to 2T. And yet after a few minutes of sitting at the Windows desktop, it blue-screens, dumps memory, and reboots.


With my old 2x1GB 1333 memory, everything works great.


I have not done as much troubleshooting with the Corsair as with my previous attempts (Patriot and then Crucial), but with the other RAM what I found is that Memtest would run successfully all night, but then the computer would blue-screen fairly quickly when booted up. This happened with one stick or both sticks inserted, regardless of which stick went into which slot. Oh, shortly before beginning this project, I updated the BIOS from F5 to the most recent F7, cleared CMOS, loaded optimized settings, etc. Immediately after installing the new Corsair memory, I went into the BIOS and did another "Load Optimized Settings".


I'm at a loss with this, unless my motherboard is broken in such a way that 1GB sticks work but 4GB ones don't. Does anyone have any advice or anything to try?


Thank you!


P.S. This is very similar to this post, but the original poster didn't appear to have the correct memory. I *think* that I do. ?!


Server specs:

Mobo: GA-H55M-S2H revision 1.0

CPU: Core i3 540

Working RAM: Crucial CT2KIT12864BA1339 2x1GB DDR3 1333

Graphics: Built-in

Drives: Two 2TB WD Green drives, two 2TB Samsung drives, 1 old IDE drive.

PSU: Corsair 400W CMPSU-400CX

Link to comment
Share on other sites

P.S. This is very similar to this post, but the original poster didn't appear to have the correct memory. I *think* that I do. ?!

I'm sorry to say no. That the memory you have now is not the correct memory. What RamGuy is saying is that your MB needs to have memory made from 256mb chips and anything Corsair has to offer at this time(along with most of the other manufacturers ) have all moved to making the modules from 512MB chips that would be too dense for your MB to run . Basically making them incompatible. If you can find modules made from (16) 256mb Chips, 8 on each side or what is called double rank,then they would work. But the Corsair modules are made with (8) 512mb chips on just one side and won't work.


I'm sorry to say Corsair no longer makes those modules because most of the chip makers have quit making the lower grade chips. Unless you can find older stock somewhere it may not be possible to upgrade and might be a better idea to find a newer MB rather than trying to find the memory to work in that system.

Link to comment
Share on other sites

Thanks for your reply, peanutz94. Are you sure those sticks are one-sided, though? The revision number is 8.16. From RamGuy's explanation on the other post:

Posted By Ram Guy

.1 means 256MX8 so would be 2R for a 4G module

.2 means 512MX8 so Would be 1R for a 4G module



1.50V ver2.13 would be 2R for 4G module

1.50V ver2.21 would be 1R For 4G Module

If I'm understanding this correctly, that means that my ver8.16 sticks are, in fact, double sided. And if I peer underneath the head spreader, it *looks* like there are 8 chips on each side. It's hard to tell for sure, though.


Does that change your statement, or am I still out of luck? :)

Link to comment
Share on other sites

Yes, that would change my statement. Those would be 256x8 double rank for a 4 gig module and should be okay. That info can be found here .



The only other thing i can suggest is to try manually setting the DIMM voltage to 1.55v Some MB will actually undervolt the memory despite what the BIOS say they are set to. Basically the actual voltage at the modules may not be a true 1.5v and could potentially contribute or be the cause of the issue.


With three different sets of memory all with basically the same results it makes me scratch my head too.


Have tried testing the modules 1 at a time with memtest86 (there is a link on the left if you need it) to see if they produce any errors. If so go ahead and set the voltage to 1.55v and then retest to see if the result get any better.

Link to comment
Share on other sites

Hi, thank you.


Well, I increased the voltage to 1.56 (that was the next increment after 1.50), but it still crashed right away. I will try running Memtest again just to get another data point. With the first upgrade attempt, I ran Memtest for about 12 hours overnight without a single error; then it blue-screened within 5 minutes of booting into Windows. Very strange.


I wonder if it's a power supply issue? I have five drives installed, but according to an online wattage calculator my 400w supply is well over what is being drawn (Core i3, no video card, and five hard drives). Still, who knows?


I can't believe that the simple exercise of upgrading memory may turn into a complete motherboard refresh and system reinstall.

Link to comment
Share on other sites

Damnit! LOLl Now i thought i screwed up , and didn't but actually did. When thinking about this i wanted a quick look at your system specs again and looked at what you had in your specs dropdown instead of scrolling all the way to the top to your original post and realized it was the Gigabyte board and not the Abit board you have listed in your specs. So for the sake of keeping things straight I deleted my last post.w


So now yes, your right 2x4gigs should work. But I'm out of ideas. Since you have tried three different vendors memory it would usually indicate a bad board. But yours is stable with just 2 gigs in it.


The best I can tell you is to let RamGuy see this and maybe he might see something I missed.

Link to comment
Share on other sites

Haha, yeah... my regular PC is listed in the drop-down, but this is for my server and there doesn't seem to be a way to have more than one system listed in the drop-down.


Well, thanks again for your help. Hopefully RamGuy will see this thread and have something to add. I'm not getting any help from Gigabyte Support, so if nobody here has any other ideas then I'll have to scrap the existing system and buy a new motherboard.

Link to comment
Share on other sites

You didn't by any chance run the Gigabyte utility "Easy Tune" with your last RAM and save the parameters to be loaded on the next boot at some point in the past did you? That could be messing up the timings of your new RAM in Windows, no matter what you do in the BIOS.
Link to comment
Share on other sites

The only thing that makes sense is that something is not particularly liked by the "load optimised settings".


What do the settings in the MB Intelligent Tweaker(M.I.T.) actually say?


Personally I have NEVER loaded the "load optimised settings". I have always gone through the different BIOS menus and changed the individual values.


In your shoes I would put the values in "Advanced Memory Settings" down to 1066MHz and above all, put the value for "Performance Enhance" to "Standard" instead of "Turbo" as the load optimised defaults will set it to.


I have had some issues with Gigabyte boards when anything but the option "Standard" has been selected.


Barring that, jot down the values the BIOS has written for the various options and post them here.

Link to comment
Share on other sites

Are you sure that the RAM modules are getting enough airflow and that it couldn't be that they are just plain and simply overheating and shutting down as a result?

Unless the modules were being pushed past 2.0v then heat would not be an issue. But at that voltage the CPU/MB would be damaged .

Link to comment
Share on other sites



just covering the bases, and if the RAM modules are effectively being insulated then overheating could be a possibility - no matter how remote.


We have pretty much covered everything else, and when I wrote that this morning to smirk I was remembering the old Sherlock Holmes saying, "If you have eliminated everything else then what is left - no matter how unlikely - is the cause". :)

Link to comment
Share on other sites

Your timing is perfect -- I was just about to return the new memory this morning, but I saw your post first so I reinstalled it and adjusted the settings. However, it blue-screened about 30 seconds after logging into the Windows desktop.


Here are the settings:



I have manually set tCMD to 2; it would have defaulted to a value of 1 if set at Auto. About the possibility of overheating, I know you had to ask but I don't think that's the culprit. Although I don't have a way of measuring the temps, everything feels cool inside and the memory is unobstructed and is by airflow.


Do those values look ok to you?



Link to comment
Share on other sites



One thing I noticed right away is that your QPI setting is at a ridiculously high value of 5868.85 MHz (44 X)


Dial that back to a multiplier of 23x for the QPI (so that it is running at the same frequency as your CPU) at most. That was a pretty glaring eyesore when I saw it.


I have the feeling that this will cure your woes.


Should I be wrong, then keep the QPI at 23 and go with the timings below, they are guaranteed safe and if they don't work with these then you can send the RAM back


I won't put up a screenshot of my BIOS settings simply because the names are written a bit differently, so to avoid any confusion I will use the names from your screenshot instead:


tCL = 9

tRCD = 9

tRP = 9

tRAS = 24

tRRD = 5

tWTP = 21

tRFC = 108

tCMD = 2


I am however pretty confident that just reducing the QPI frequency will get you sorted.

Link to comment
Share on other sites



Oh wow, that's really odd about the 44X. I checked the BIOS and QPI was set to Auto. Changing it to 23X wasn't an option, so I set it to 24X (3200 MHz). Interestingly, with anything below 24X the computer wouldn't POST.


Anyway, I manually set the timings to those that you listed, and also switched the "Performance Enhance" setting from Turbo to Standard, but the computer still blue-screened. I was really hopeful this time because it didn't happen right away, but I left the computer on and came back an hour later and it was dead in its tracks.


Thank you so much for your help, I really appreciate it. If you're out of ideas then I think I'll start speccing out a new motherboard + CPU.


Thanks again!

Link to comment
Share on other sites

The only hardware things left are pretty exotic (such as the CPU not making proper contact with the motherboard) and highly unlikely.


Obviously the changes you have made had a positive effect because the system is running a lot longer before you get a BSOD.


The one thing that I have left to suggest is that it could be that you have now cured any hardware reasons for the system going belly up, but there may be some Operating System problems.


For instance, if you you boot into "Safe Mode" does the system still blue screen?


Have you tried resetting the virtual memory? Basically changing its size to erase the previous contents. You have to remember that the system has been crashing a lot and this could have led to corruption of the virtual memory file "pagefile.sys" or the Operating System itself.


If, after booting into safe mode and the virtual memory has been wiped and the system is running stably, then your next step would not be to buy another motherboard but rather to reinstall Windows.


Another thing I would suggest for the future, is not to load "Optimised Defaults" but rather the "Fail-Safe Defaults" first. Personally I can't remember any time when I have ever loaded the "Optimised Defaults".


If however nothing works and you are going to get yourself a new motherboard and processor for your home server, could I suggest an AMD A10-5800K. I recently built up my new NAS and for the first time ever I decided to go with AMD instead of Intel (I got the A8-5600K because it was on offer in a bundle for a price I could not refuse) and I am really happy with it in every respect.


If you want to, you can reach me on Skype under the name Nec_V20 if you have any questions.

Link to comment
Share on other sites

Hey, thanks again for the ideas. I'll try Safe mode tonight, but if software were the culprit then wouldn't you expect the computer to experience the same issues with the old, 2x1GB RAM? Instead, it's 100% stable with the old memory.


I'll check out AMD, thanks!

Link to comment
Share on other sites

The thing is that if it were just one set of RAM you had tested then pointing the finger at that as the culprit would be the way to go. However this is the third set of RAM resulting in the same error.


As I said, try booting into safe mode, then wipe the virtual memory and recreate it.


The virtual memory is vital to the functioning of Windows and if that has become corrupted then you can get some really perplexing errors and crashes.


Look in the Windows help for instructions on how to get to the virtual memory, then, if there is a check mark in "Automatically manage paging file size for all drives", then uncheck it. Then go to "Custom Size" and enter the same value for "Initial size" and the "Maximum Size" (we can go with 2048 MB).


If it is already on "Custom Size", just change the value (say if it were already on 2048 MB then change the values to 1024).


Reboot normally and see what happens.


As I said, if you want to talk about it then you can reach me on skype under Nec_V20 where I can go into it in a lot more detail than in this thread with the haphazard too and fro of our discussion.

Link to comment
Share on other sites

  • Corsair Employees

For the modules to work with this MB they would have to be

1.50V Ver. X.1X and I would check with the MB maker and see if there is a BIOS update available. But from everything you have posted and the fact you tried three different sets of modules it sounds like the MB and or CPU you have are just a bit picky when it comes to memory. Do you have the ability to test the memory on another system? If so and they work with out issue on another system I would maybe try and ask Intel to swap the CPU.

Link to comment
Share on other sites

  • 4 weeks later...

Hey, it's been a while but I wanted to comment on the crazy RAM issue I was having. It turns out that the RAM was fine (probably all were fine except the sticks that prevented the computer from posting). The problem was with my OS! Something must have gotten corrupt in it, I'm not really sure at this point. All I know is that other OSes are running fine on the same hardware, it's only my original OS that kept bluescreening with more than 2 GB of memory installed. I've since loaded Ubuntu, Windows 7, and then ESXi + Windows Home Server, and everything has ran flawlessly.


So thanks for all the ideas, but it looks like fortunately it wasn't a hardware problem at all. Oh, and incidentally it wasn't the swap file, either, but that's a good thing to keep in mind for the next oddball error that comes along. :-)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...