Jump to content
Corsair Community

SSD Force 3 120GB failed to update


Recommended Posts



I have tried to update my old SSD Force 3 120Gb from Corsair, because sometimes my system gets some random freeze "spikes", don't know what i should call it.


My firmware is 1.3.3, is never been updated by me, but today i tried.


I ran the program Corsair_FieldUpdater_v1.1, started it as administrator.


Clicked on update firmware and picked the right file 22788. Once i clock process, i only get a Red icon instead of the green one you should get if it was succesful.


The errorcode i get are:


FATAL_ERROR, firmware download failed with error (Ecode 00000057).


Can anyone help?

Link to comment
Share on other sites

If you can't "roll back" the drivers for the AMD chipset, and have ASMedia Cotnroller, simply use the ASMedia controller and it should work as well. The issue I seen with this is AMD drivers register as SCSI and not ATA causing issues with DUT (drive under test) when trying to retrieve information from the FW update Tool. This is a common issue with AMD drivers and is not seen on Intel based chipsets. =)
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...