Jump to content
Corsair Community

Bad psu, mb or cpu?


Recommended Posts

Hi, i hope you guys can help me with a strange problem i am having.


My system:

Corsair AX850w

corsair 650d

corsair dominator platinum 1866mhz

corsair h100i

Asus sabertooth z77

Intel I5 3570k (no overclock)

Windows 8 64bit


So the problem is as following: I bought a Sapphire radeon 7950 Vapor-x edition that worked good for a while and not anymore. The problem was that when i restarted the machine, i had picture through the post, and until i hit the windows 8 logo, and from there everything stopped. So i had to restart, and then the windows repair thing stated that i had to repair the computer. When i do that i have picture, under the repair So i sendt that back and got an Asus Radeon 7970 directcu ii top. So when i tried that card i got the same problem as before with a displayport cable between gpu and screen. So, just to try it out i used a DVI cable and than it worked like a charm. Tried some games, all good. But then i had to restart the system, and then the same problem was back again. But when i use the intergrated gpu (intel hd4000) with the same displaycable everything is ok. I have good picture and everything runs smooth.

*Note* The ram, mb, gpu`s, and cpu is new, and the 650D and AX850w is under 1 year old.

I have added pictures just to show you what i can see before the problem starts.


What i have tried:

- Reinstall windows 8 64bit. I have picture during the install until i have restarted the system (when it says prepearing for first boot) the picture disapears and won`t come back.

- Tried all 3 pcie ports just to check that the ports are ok. No difference nomather what port i use..

- updated to newest bios and loaded optimal defaults

- Had contact with asus support, and they said that it sounds like a psu problem.

- Tried a 7950 and a 7970, same problem

- Booted with only the nessesary things to roul out that other components is bad.

-cleared cmos

*edit* has also checked that none of the pins on the mb cpu socket are bent or out of place.


The thing that i find strange is that when i tried the DVI cable the asus 7970di2 top worked perfect until reboot. what can the problem be?


Best reguards



ps, please forgive my english :sunglasse




Link to comment
Share on other sites

thats a new one on me, but I am really sure it's not a PSU issue. I am thinking of the problem being related to the graphics cards drivers and windows 8. do you have the correct amd driver for the cards? did windows update install a updated amd driver around the time the problem started?
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...