Jump to content
Corsair Community

Firmware not recognized


Recommended Posts



I received yesterday my new keyboard, an K90.

the first part of the installation was fine, Seven 64 pro recognized it, both USB were on 2.0.

The KB was working : lights were on, I was able to use the different keys

I dl the latest version of the firmware on corsair site.

I tried to install the firmware 1.31. The first install failed but after 2 tries the installation was succesfull.

I installed the program to get the different profile.

I was able to program some G keys but I want to use it with SWTOR and I must use it as hardware, si I click on the small button at the bottom left.

The programm tells me that I don't have the latest firmware. If I close the program (that stays resident) I was unable to click on this window again.


I tried to remove all and reinstall 3 or 4 times, for nothing.

It's only the harware macro that failed and I can't save the profile on K90, all else is working, but I can't use it for my game.

It seems that the firmware was not installed even if the box says yes.

I must say that I launch the install in normal mode I don't give the installation program an administrator status.

Do you have an idea for help?

Thanks and sorry for my bad English (it's not my mothertongue)

Link to comment
Share on other sites

it's in French so I'll translate it



Software :

USB keyboard :

VID : 0x1B1C

PID : 0x1B02

Builder : Corsair

Product : Corsair Vengeance K90 keyboard

Firmware : NA

Windows : Windows 7 professional 64 bits



Hope this helps.


I tried a new install but it failed again.

I 'll ask the shop for a refund

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...