Jump to content
Corsair Community

Nova 2 firmware updates?

Recommended Posts

later this month i am going to be upgrading my OS from ubuntu 10.04 to xubuntu 13.04

i wanted to make sure i had the latest firmware, i bought it on 04/22/2012 so i would think there would be a update by now, but i cant even find my ssd in this thread

after i originally i asked customer support if i had the latest firmware they said there had been no updates, but customer support seems to be broken, i tried both firefox and chrome


this is my ssd:


Link to comment
Share on other sites

  • 3 weeks later...
  • 7 months later...
A Nova 2 firmware update recently came out: http://forum.corsair.com/forums/showthread.php?t=117997


Can you flash the Nova V128 (1st Gen) with this firmware? I recently added more ram to my system and it crashed it hard at 1st! had to do a fresh install of windows 8.1 everything seems ok but there has been some odd bugs here and there... so i ran HWINNFO and it says I have 12% life on the ssd also its had this line?



[C6] Off-Line Uncorrectable Error Count/Total Count of Read Sectors 181/Always OK, Worst: 52 (Data = 148110)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...