Jump to content
Corsair Community

M60 Firmware update problem fixed


Recommended Posts

hi guys,


after updating my m60 today with the new firmware (v.1.11) basically nothing was working anymore (except LMB RMB and the scroll wheel). I tried to find a solution here on the forums but the pinned thread (http://forum.corsair.com/v3/showthread.php?t=104856) didn't help me as I wasn't able to select 'corsair' in the list of manufacturer (win 8 issue maybe?) and reinstalling the driver manually didn't improve anything as my laptop wouldn't recognize the m60 anymore.


After an hour of browsing through the forums I stumbled across a thread where someone mentioned problems with usb3.0 ports and the m60. In a desperate move I switched my m60 into an old laptop of mine (usb2.0 ports only), downloaded the firmware, reflashed the mouse... and the problem was solved. Every button was working again and the mouse was finally recognized as a m60 again (on both laptops!!).


Thought I'd share my experience here as I'm quite sure no one mentioned this "solution" before.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...