Jump to content
Corsair Community

Playback Switching - V2000 & Desktop Speakers


Recommended Posts

So, I'm unsure on how to set this up correctly.


What I want to happen is if I turn on my V2000 for all playback to happen through my headset. When I turn the headset off I want all playback to go through desktop speakers.


This isn't happening. It seems like certain programs like iTunes will only play through one or the other.


Another issue I have is that I have a record player plugged into the Line-In on my sound card. But it plays through both speakers and headset simultaneously.


I have integrated RealTek Audio Chipset with RealTek's HD Audio Manager installed.


I'm on Windows 7.


All help is greatly appreciated!

Link to comment
Share on other sites

There is no auto switching as its an OS limitation to do so without software. As for the Line-In, you may have to disable it when its not in use under playback devices.


I remember when I was on WinXP and I had a usb headset from Platronics (Or whatever there name is) that if I plugged it in, all audio playback would go through it. Then when I unplugged it all playback would go through the desktop speakers.

Link to comment
Share on other sites

  • 3 weeks later...

I have done this in the past, My headphones are set as default communication device and my speakers set as default device. When i turned off the speakers the sound would be sent to headphones.


I no longer have the speakers so I cant test if it would work the other way around, I should add the speakers where USB speakers so would I assume work the same way a USB headset will as far as powering them on and off.


So usb headset set as default device and speakers set as default communication device.


To be clear I mean only in playback devices here not recording. So right click playback devices and change there.


I hope it works for you.


I should also point out this works in both windows 7 and 8


** EDIT having tested this with a vengeance 2000 headset I can tell you it doesnt work as the wireless dongle remains active so for it to work you would need to unplug the dongle, I tested that too and it did work.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...