Jump to content
Corsair Community

M60 Software installation on Win8 Causes CRASH


Recommended Posts

I just build a small system and hooked up an M60. I thought win 8 had the drivers for the M60 but the system flagged it and told me to install device software. I came to the Corsair website and looked up the M60 driver info. I began installation of the M60 setup 080612.exe but it cautioned that I needed to be running 1.1 or later. Huh? Alright. M60FwUpdate v1.11 sw-v1.1 080812.exe is started. System FAIL. Reboot.


I tried to install the drivers again but each time resulted in a system lock up.

I even tried to install the exe first but still a Crash.






Win 8 64

Gigabyte GA-78LMT-S2P

CPU AMD Athlon II X4 640

8 GB Corsair Memory

Kingston 112 GB SSD

Segate 1 TB Slave

Radeon HD 7750




Ran as administrator after re-downloading. No issues and installed without crashing. All updated.

Link to comment
Share on other sites

Does it BSOD or restart automatically?

If it restarts automatically, turn off auto restart in advanced system settings.


Have you tried running it as admin?

Have you tried running it under compatibility mode?

Latest BIOS and chipset drivers?

Link to comment
Share on other sites



It boots to a need to restart. I am still learning Win 8 and to be honest I wish I had stayed with Win 7.


I will try and run the install as an administrator however I am no longer getting the message from the system that I need to install drivers. However I don't have the M60 software installed to set up the mice so, ya... there we are.


I will try the admin rout when I get home. Thank you for the advice. Didn't occur to me to try that.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...