Jump to content
Corsair Community

Vengeance 2000 issue


Recommended Posts

Hi! Little conundrum. First let me say that this headset has been working flawlessly for me since the fall; no issues with sound, the microphone, or cracked plastic.


This morning, the sound suddenly cut out, the USB dongle is flashing, and I cannot seem to re-pair the headset to it. The last week or so when I have turned it on, Windows has given me a message saying that a device is unrecognized (though it was still functioning).


I have in no particular order: tried the dongle in different USB ports, made sure the headset is charging properly (no solid amber, flashing as it should be), updated the drivers, attempted re-pairing manually, etc.


When I hold the power button, regardless of whether I'm trying to pair it or simply turn it on, it sits solid blue for a few seconds, and then turns off. If I hold it down longer, it just repeats that process endlessly: solid blue, off, solid blue, off. It is currently green and fully charged, sadly I can't even turn it on properly to try a full discharge of the battery. Any help would be appreciated!

Link to comment
Share on other sites

There are no conflicts in device manager; as I said, when i plug the headset in itself to charge, it's as if Windows is trying to detect it as a device. That started happening about a week before it gave out.


Yeah, I've tried it across three different computers as well as on Windows 7, XP, OSX and Ubuntu just to make certain.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...