Jump to content
Corsair Community

Corsair Vengeance M90 Performance not working


Recommended Posts



For not to long ago, maybe 3 months, I bought an Corsair Vengeance M90 Performance. It worked good for a long time, I didn't install the drivers or update the firmware, and I didn't use the buttons other than the basic ones (rightclick and leftclick and scrolling). About a week ago, I tried to update the firmware and install the drivers cause some guy told me it would improve the performance of it when I had the right software to it etc, so I don't remember 100% what happend, but after I updated the firmware something wierd happend, the corsair light stopped having a light inside it stopped working... I've tired like 90% of the tutorials out there, but I cant get it to work again! Can anyone help me figure this out?


It was bought at komplett.no (#1 norwegian tech shop)

So yeah, I live in Norway.


Hope someone can help me


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...