Jump to content
Corsair Community

No Power - Need Help - Doing Something Wrong?


Recommended Posts

I really need some help. I have my new Corsair AX860 Power Supply but it doesn't appear to be working like the earlier one I RMA exchanged. This leads me to believe perhaps I'm doing something wrong in my hookup rather then the PS being defective. I've hooked up the big 24-pin ATX power connector to the motherboard. Both ends clicked in place and it seems to be good.


Here are pictures of the upper hookup with the 8-pin connector (this is the 12v hookup).


Picture upper hookup:



Picture power supply:



Note: I did have the panel connections hooked up when I tried and I unplugged them as pictured to try again.


Since I was able to power up the motherboard with an old PS I had and since the big connector is hooked up right I'm guessing I'm doing something wrong hooking up the 12V 8-pin connector. See the first picture above I'm using the 8 slot "CPU" cable that came with the sleeved set of blue cables I ordered from Corsair. The other picture shows the 24-pin connector and several six pin cables plugged in and me holding the 8-pin other end of the CPU cable. I've plugged this in both the top row and the end on the lower row (marked CPU4+4).


1. Is this the right cable to use?


2. Which slot exactly should I use on the power supply for this cable?


3. I have the PS on "normal" mode (button on the back has normal and hybrid) is this correct?


I've checked to make sure it's plugged in well, I've checked my power strip, tried different cords for the power supply, made sure the power supply and strip were "on", tried it both with the RAM and without the RAM, I've tried everything I can think of and I'm completely stumped. Since I find it highly unlikely I have back to back bad PS and since the motherboard did come on and flash error codes with the old 300w PS I tired out its clear i am doing something wrong. I just can't figure out what.


One note the old PS I tried that did power the motherboard only had a 4-pin connector for the upper connection not an 8-pin but I followed the motherboard directions as far as plugging it in. Maybe one of those other pins is bad?


I do have the video card hooked up like this. It had one 6-pin and one 8-pin connector and I've hooked it up with this PCI-E cable with 6 into one and 6+2 in the other. I posted about a week ago and was told this was the order but I'm posting a picture just in case it's not correct. I just want to make sure this isn't the problem. I do have that PCI-E cable pluged into the PS.




Any help would be appreciated. I am at my wits end with this I don't know what I could be doing wrong.


Erik. :[pouts:

Link to comment
Share on other sites

I just noticed something. The big ATX cable has one end with the 24 pin connector and the other end split in two with a 18 pin and a 10 pin. On the blue cables I ordered the smaller 10 pin one says "1200 ATX only" but on the black cables that came with the power supply the smaller one says "860 ATX only" (see picture). But the pin holes look identical. Mislabeled or is that blue cable incompatible? Or do I not use the 10 pin connection part? ( I hadn't tried it until now it was unplugged before).




Now on the power supply itself there is one connection with 18 pins marked "24 pin ATX" and on the row above there is a 10 hole connection also marked "24 pin ATX".




Earlier i didn't have both sections plugged into the PS earlier just the 18 pin part. Do I plug both in as the picture above? (That didn't work either).


I tried plugging in just the big ATX connectors (both 18 & 10 pin parts), the 8 pin CPU 12V ATX connection and the video card PCI-E connections and unplugged everything else. Still nothing. I find it impossible to believe I have had two bad PS in a row and now believe I am doing something wrong since the motherboard did power up with the other power supply. I just can't figure out what.



Link to comment
Share on other sites

Figured it out after all this. The 8pin CPU power connector cable (the blue one) is faulty. I've tried a couple other cables and everything works fine and this power supply did pass the paperclip test. I'll do an RMA for this one cable if possible (can you do that? The other cables are in the case now).


I'm typing this from my new computer which is fully operational so I'm ecstatic!!!!! The new power supply is humming along nicely and the H80i cooler with the quieter Corsair fans I bought seem to be working great. The Vengence RAM looks great too in matching blue.


Erik :biggrin::biggrin::biggrin::biggrin::biggrin:

Link to comment
Share on other sites

Yes, you should be able to RMA and request just the cable.

You have two options...One is to use the link on the left to request an RMA for your PSU, but in the description area let them know you need just the cables.


two...Call CS and request the cable that way. Usually calling in will be faster than using the automated RMA system.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...