Jump to content
Corsair Community

help cant get 24-pin installed from ax1200i


Recommended Posts

i honestly dont know it just doesnt feel right to push this hard and it doesnt even clip in

this is my first time build so maybe im thinking too hard



im trying to connect the 8 pin part to front of the psu

it was easy to connect the 4 pin one i think its 4 pin, anyway the smaller one with least pins

as for the larger part of the 24 pin


ill try my best to illustrate this








so basically as i try my to push in the connector to psu i find some resistance, kind of tough so i looked at it and noticed that green thing from the top part its preventing that clip from the connector going in, as i try push in the connector it just starts to bend upwards


im not sure if that green thing should be there?


i hope this is normal and its just me overthinking this part

i tried keeping the clip that bends down by holding a pen on top and it just doesnt cut it


its still pretty difficult and i didnt want to force it


if this is normal with the green thing in the way then ill force er in and clip the son of a gun


but for now just want to make sure



also that green thing, its a bit circular and it has some letters on it

i cant tell what it says though, , it looks like the middle of a word or something


i hope this isnt big deal

anyway please let me know what i should do

k tk


take care

Link to comment
Share on other sites

Thats a new one to me. I would have it swapped out.


i looked at the psu in a review to find that green thing i was looking at

closest is this



the green thing at the top thats probably whats in the way so i cant lock in the 24pin

well i never try to force it anyway

i never had to force in the smaller end of the 24pin so yea....

Link to comment
Share on other sites

Thats a new one to me. I would have it swapped out.


k i tried as you said


when i brought it to the shop

had the tech test it out

he said its just a capacitor in the way


had it turned on tested it out and such


so it works


but its supposedly a capacitor!


so really should i rest assured everything will be fine, im just having last second thoughts about this

so i realized you know i should definitely ask corsair


i have less then couple weeks left for store warranty and i just need to know


because i need at least the go ahead to return the PSU or not because now i know what the problem is but the psu is still functional




could something go wrong and i end up frying my system?

i mean i just need to know if this capacitor is slightly in the way should i be worried, i just dont know anything about electronics


the tech convinced me it would be okay

sure i felt assured but



I just want to double check with you guys so please let me know if i should return it or not,

i mean the locking mechanism works, its just over time i wonder if the capacitor could be somehow damaged from being rubbed up against for so long as it does take more pressure to lock it in thus pushing the cap further up


im certain my system will cool very well at least for now

i might run an sli system soon

in terms of heat and time

question is could something happen to this capacitor?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...