Jump to content
Corsair Community

CorsairLink2 problem..help


Recommended Posts

I recently put together a new system with Windows 8 Pro 64bit with a H80i. Everything was fine with CorsairLink2 when first started.. I could see info regarding the H80i (changed the LED color etc.) But now whenever I open CorsairLink2 I don't see anything regarding the H80i. I can see the temp of the CPU, the graphic card, even that hard drive; but nothing on the H80i. Heck I can't even find the section on changing the LED color. I've uninstalled and installed a few times already. No luck. I suspect the H80i is working as I can hear the fans speed up if I start rendering a 3D scene (for example)


I really don't know what the heck has changed beyond a boatload of Windows 8 updates. Beyond that I'm stumped. I'm using the latest software as I just set-up the system yesterday. I know that the new software supports Windows 8 and their was some issue with Windows 8 before this. Could some Windows8 updated messed something up? Is there something wrong with my hardware now?


The H80i is cooling my system but I have no access to it!


Thanks in advance.

Link to comment
Share on other sites

I have the exact same problems on a Win 7 64bit system. Use a mini USB to type A cable and connect your H80i to a USB port. This is the only solution that worked for me.


Corsair Link updates, changing USB mobo headers, etc did not work (I tried everything after trawling through the forum)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...