Jump to content
Corsair Community

AX760i Won't Boot..


Recommended Posts

Hello guys.


I purchased the AX760i 20 days ago,i was really happy with it!


I installed it in my pc and it worked just fine..today i tried to power my pc but it just won't boot!!!


I hear a clicking sound and nothing happens...i tried to use the self test (without any cables attached to the psu),it lights up green-does this clicking again-and then red :mad:




i7 2600k

P8Z68-V Pro

2xGigabyte 7950's

2xVertex 4 128GB

3x1TB HDD's


Please answer asap...this drives me crazy,i made an investment on this PSU and now my work has to wait due to this issue :brick:

Link to comment
Share on other sites

Sorry to hear your having issues. Unfortunatly it looks as if your only recourse is to RMA it.


Please use the link on the left to request an RMA. Once you get your case number you can call CS and request an advanced replacement and you can have a new PSU in just a couple of days.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...