Jump to content
Corsair Community

corsairlink2 and h100i - fan mode not working


Recommended Posts

till recently everything worked fine but from time to time changing fan mode doesn't do anything.. quite balanced performance or maximum it doesn't make any difference. everything works fine but modes are not changing fan speeds.

I think that it happened before and worked fine after restart.. will try same again but if it keeps loosing effectiveness for changing fan speeds... any idea what could be wrong?

got last version of corsairlink2 and firmware is 1.0.4


Do you suggest updating to 1.0.5 firmware?

Lastly I ordered set of noctua nf-f12 fans maybe that alone could be reason to upgrade firmware anyway, but I didn't had any problems till recently so I didn't wanna play with firmware.


Thanks for ideas.

Link to comment
Share on other sites

When you couldn't change the fans speed, does your LED settings are locked too?

When you couldn't change the fans speed, try quiting/closing the CL software and start it up again. Does the software could detect your H100i in the device section? --> It is in options tab.

What else is connected to your motherboard's usb header?

Try unplugging any other cable from your mb's usb header and leave only H100i's usb cable.

Does that make's a difference?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...