Jump to content
Corsair Community

Corsair M65 no longer tracking after an hour of ownership


Recommended Posts



I received a Corsair M65 mouse this morning, and I have connected it to my PC, installed the drivers, updated the firmware, and everything worked great.


I decided to move some wires around so that it was nice and tidy around my desk, so I shut my PC down and unplugged a few things to move them around. One of which was the M65. Initially I had it plugged into one of the front USB 2.0 ports on the front of my case. I have now plugged it in on the back of the motherboard.


Upon booting into Windows, I can no longer move the mouse cursor, at all, on any surface. Clicking L/R, the back/forward buttons, sniper button etc all appear to work correctly, but the mouse is otherwise completely unusable. I can open up the Corsair driver suite and I can turn off the LEDs, adjust sensitivity etc, so I can see that Windows and the Corsair drivers are picking the device up properly.


I have tried booting into the BIOS to see whether the mouse works there, and again only scrolling and mouse clicks are picked up, but mouse movement is ignored.


I have also tried the mouse in two other computers, a laptop and an old Dell prebuilt. The mouse performs exactly the same in these computers too.


The mouse pad I use is a Steelseries QCK, I have also tried the wooden desk, my jeans, my arm, the wall, all of which do absolutely nothing.


I know there's another thread just below with a similar issue, but at least they can get it to work if they replug the mouse, I can't get it to work at all.


Anyone got any ideas, or am I going to have to send the stupid thing back to the retailer?


Thank you :)


EDIT: I'm just going to get a refund from the retailer, I've tried everything I can think of, I have tried every tip I've read in these forums and others. I have successfully updated the firmware 3 times, I have tried all the Lift height settings, all the report rate settings, Angle Snapping enabled/disabled, different DPI settings, various surfaces to use the mouse on, and I cannot get a response from the laser at all. No attempt to make the mouse cursor move works, on any PC I have tried this on. I even used a USB OTG cable with my Android mobile phone (which works great with my previous mouse), and it doesn't work in there either.


I've owned 3 mice in the last 10 years. A Logitech MX 700 which worked fine for 5 years until the left-button stopped working, I then had a Logitech MX Revolution which has worked fine for the following 5 years, but now the mouse wheel is a bit dodgy and the battery life is awful, and then I get this mouse and it fails within an hour...

Link to comment
Share on other sites

  • Corsair Employees
If you still have the mouse Crugath, I'd love to get it back for a failure analysis as simply changing USB ports shouldn't cause the issue you're experiencing. However, if you returned it, I understand and will pass your comments and feedback to the product team so we can look deeper into it.
Link to comment
Share on other sites

I do still have it, but I have a refund authorised with the retailer (Ebuyer in the UK) and I'd quite like to get my money back ASAP. Fortunately they're footing the bill for shipping it back to them, which I'm glad I don't have to pay for.


Is there any more detail I can give you to help with feedback?

Link to comment
Share on other sites

I'm using the latest drivers that are on offer on the Asus website for the chipset etc. If there's separate USB drivers, I'm unaware of them. Windows 7 Pro x64 is fully up to date, for what it's worth.


BIOS revision is 0801 which has a build date of 08/15/2011.


None of the USB ports have been damaged, on either the case front panel or on the motherboard IO. I haven't had trouble with any other USB devices before.

Link to comment
Share on other sites

Aye, but I've read of many issues in the Asus forums with newer revisions of the BIOS that you can't roll back from once you're upgraded due to the way the BIOS is flashed, so I left well alone.




As you can see in this thread, people are having problems when not following a very specific upgrade path with the BIOS, and the moderator, Howard, suggests just buying a BIOS chip that has already been programmed with the latest BIOS revision. so I'd rather not go through this, when my system is completely stable and presents no issues that require a BIOS upgrade to fix.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...