Jump to content
Corsair Community

Did windows update

Zeros and ones

Recommended Posts

So I did a windows update a while back. Nothing more and nothing less. Every time I start the Corsair link, Seirra2service crashes.


Here are the things that I tried.


1) tried shutting down everything that was running in the background for corsair link 2 and start the program again. This has worked in the passed but not this time around.


2) I have un-installed the whole program. Restarted the computer. Installed the link software again. Restarted the computer and than started the Link software. Seirra2services still crashes


If windows updates completely destroys the software to a point of no use, than what hope do we have the the other issues will actually be resolved correctly.


I need some help please resolving this issue. Thank you guys very much for your time.

Link to comment
Share on other sites

what was the update?,did it include a .net framework?

can you restore before the update?


This is my thinking as well that the netframe was updated. Please verify in windows update if the was the case if so you can roll back the update. Seen this a few times as well as on my own computer. Current software has issues with newer .netframework. Although if you update to the newest which is not part of windows update some say that has worked as well.

Link to comment
Share on other sites

There is a new software update.


Here's Corsair LINK v2.3.4816




  • Windows 8 Support
  • New Hardware Detection and Monitoring Engine
  • Firmware flashing to Commander units prior to firmware 2.06 now supported
  • CPU temperature for all AMD platforms now supported
  • Device Icon’s now have three selectable sizes
  • Communication between multiple devices has been improved

Link to comment
Share on other sites

Ok, So i installed the new software. It is working but I have two things that have come up.


the first one is the my cpu fluctuates from 0 to 11% consistently. I did not have this happening with the old corsair link.


the second is, it seems that the option to change how you monitor your power supply (ie, setting to see how hot it is or how much power it is consuming) is not available and by default you can now only monitor its temperature.


what can we do to resolve these issues?


Thank you

Link to comment
Share on other sites

Do you mean the power tab?


If it's not there, delete your profile and click "Reset to defaults" (Options tab) and restart the software. Does it help?


you are close but no. I most likely did not express myself correctly.


The power tab is present and is working as it should. But what I am looking for is in the systems tab.


previously in the past link software when you did a fresh install you see the temp for your particular power supply. In my case I have the AX1200i. When I would select that object the side windows would appear and under device type I was able to select either to monitor temp(set at default) or power usage.


I do not have that ability anymore because the only option present is temp.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...