Jump to content
Corsair Community

M95 firmware update failed; now fails to start


Recommended Posts

So, hooked up my M95, downloaded the software package, noted that it says to update the firmware before you install the software, and started the update, which started fine, and then stalled at 44/54 blocks before saying that it had lost connection. Now, anytime I try to start the firmware update it says "Get flash memory information failed!" and won't do anything else.


The mouse still works, albeit at a pretty low DPI setting (800?). I can load the configurator utility, but I can't seem to save any changes I make, and the DPI adjust buttons don't work. The lights are off too, except for the top and bottom light on the left side.


Steps I tried to troubleshoot:

1) re-plug mouse. tried various ports, including the one I had it in originally (topmost port on my ATX input cluster), two other USB2.0 ports on the input cluster, a front USB port, another port from an internal header, and even one of the USB 3.0 ports. The firmware update refuses to read the flash.


2) Reinstall firmware update software. No effect.


Help! T_T


Update: Okay, I replugged the mouse again, and now it fails to work at all. Same two lights come on, but neither motion nor the buttons work at all. Faaantastic.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...