Jump to content
Corsair Community

VOYAGER slider 8GB USB 3.0


Recommended Posts

I have (2) brand new-just opened the packaging, VOYAGER slider 8GB USB 3.0 drives.. I'm trying to run them on a brand new Lenovo ideapad S405 (this thing has AMD USB 3.0 eXtensible Host Controller - 0096 (Microsoft), version 6.2.9200.16384) on Windows 8 64-bit..


Each time I insert the drives into the USB 3.0 port, I get a pop-up messages stating: "USB device not recognized".. if i insert them into the USB 2.0 ports they read just fine; I also have a Patriot Magnum 128GB USB 3.0.. I insert that into the same USB 3.0 port and it read normal and fine..


In Windows 8, if i go to PC settings>devices, when i insert the VOYAGER in the USB 3.0 port it shows me "Slider 3.0", a progress bar runs, then it states "Driver error" beneath "Slider 3.0"; I tried doing this with the internet disconnected, now it says "Setup incomplete. Connect to the internet"; if i insert it into a USB 2.0 port it simply shows "Slider 3.0" (and reads fine).. when I insert the 128GB USB 3.0 drive it states the drive name then below it says "Connected to USB 3.0"...


I went to Lenovo's Support website, downloaded and installed the latest AMD Chipset but I still cannot get the VOYAGER sliders to work in the USB 3.0 port :(: ...


Please advise, thank you!

Link to comment
Share on other sites

Attention RAMGUY, my RMA##5679176 if you could please update my RMA w/the correct product, I have quantity: (2) CMFSL3-8GB VOYAGER slider 8GB USB 3.0...


honestly, I'm not sure if sending them back to Corsair is the best route for my problem?.. if this is a compatibility issue with Windows 8/AMD USB 3.0 controller, and I'm just going to get the same devices that will produce the same problem, then I'd much rather save my time and cost it's going to take to ship these out.


is there a firmware update for these drives? or do i need a completely different device that is Windows 8 compatible?



Link to comment
Share on other sites



So I went into Best Buy with both of my VOYAGER slider 8GB USB 3.0 flash drives and tried them in an HP All in One Windows 8 touchscreen Desktop & the Dell XPS 12 Windows 8 convertible laptop.. and confirmed that the flash drives were detected as USB 3.0, no driver errors at all! One had a Microsoft USB 3.0 controller and I forgot what the other one was~??


Seems like there is an issue with using Corsair USB flash drives and AMD USB 3.0 controllers.. :-( o'well, glad my initial issue wasn't with my own computer! I never have and never will buy an AMD powered laptop! I bought an ATI video graphics card (an AMD product) and NEVER will again!


Well thanks for the support! Hope Corsair fixes their (in)compatibility issue with AMD products! These are brownie points lost with me :-/

Link to comment
Share on other sites

  • 1 month later...

I've been working on 3 different machines and have issues with 2 out of the 3.. I have:


+an AMD laptop with an AMD USB 3.0 controller


+a custom built desktop PC with Intel DP35DP motherboard, I added a Bytecc PCIe 2 port USB 3.0 card + Renesas USB 3.0 controller, and


+a Lenovo Yoga 13 with Intel USB 3.0 controller


...all running Windows 8



What I am trying to work with is a Corsair Voyager Slider 8GB USB 3.0 flash drive. When I use the flash drive in the Lenovo Yoga with Intel USB 3.0 controller, I have no problems!.. the flash drive is recognized and connects as USB 3.0, however, when I put this SAME flash drive into the machine with the AMD controller, and into my desktop, I get a notification pop-up telling me that the "USB device is not recognized" :-(... If I go into Windows 8 Charms>PC settings>Devices, it shows me Slider 3.0 and beneath it it says "Driver Error"; if I pull out this Corsair USB 3.0 flash drive, and insert my Patriot Magnum 128GB USB 3.0 flash drive, it works perfectly fine on both the AMD machine with AMD USB controller and the desktop PC with Bytecc PCIe card+Renesas USB 3.0 controller -so I know the flash drive works in Windows 8, just seems like it ONLY works with the Intel USB 3.0 controller??!!



With the AMD machine, I simply gave up and returned it to my friend... :-(



My desktop PC, i've been struggling with all day today :-/...


I've tried the driver update and the driver+firmware update on Bytecc's website.. at most windows tells me the driver installed is the latest, or in the Device Manager I get a yellow caution icon, or I try to manually install the driver and I get an error code 10 and windows tells me the device cannot turn on -OR- it tells me USB Controller cannot be found..??!!.. I even tried the Renesas driver directly from Intel but after installing it all I get is more yellow caution icons :-/



Please advise, thank you very much!!

Link to comment
Share on other sites

  • Corsair Employees
You will likely have to find out from the system manufacturer who the Chip or controller manufacturer is for the USB 3.0 Controller on your system and then get the latest reference driver from that manufacturer. I am sorry but there are still a lot of drivers that have not been released yet for Windows 8, I ran into this on one of my systems and just went back to Windows 7 on that system.
Link to comment
Share on other sites

  • 11 months later...

Bytecc PCIe 2 port USB 3.0 card + Renesas USB 3.0 controller finally updated (Yay!!!) Just installed updated drivers (from here), popped my Corsair Voyager Slider 8GB USB 3.0 flash drive in and it opened before I could even blink!... Well, it's about time!!! :-D


edit: thank you all for your response and feedback!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...