Jump to content
Corsair Community

H100i Broke after firmware upgrade


Recommended Posts

Hi, my H100i had a burn't out LED and the fans were making the buzzing noise, I was using the firmware that came with it, as I never heard the noise, so never changed.


Anyway, when I upgraded, I flashed V1.0.4, It said it was finished or whatever, but the fans ramped up to full, I went into Link, but there was only my GPU etc in the devices section, I restarted my PC, tried again, still no H100i, the unit is just showing it's red LED right now, it was the green that had died.


I have reinstalled so many times, but each time the H100i isn't detected, anyon have an ideas on how to fix this? The LED doesn't bother me too much, just want to be able to control my fans and pump, luckily I can use my 600t fan controller for now, but that's kinda annoying, as I would like the pump etc.



Link to comment
Share on other sites

If you were not aware, FW 1.0.4 was removed as it caused problems after updating the FW.


Is the H100i detected in Device manager?

Are there any errors listed under Device manager?

Have you tried a mini USB b to type A connector to see if it works?


I dont think it is detected, and yeah, I have tried different cables and differenct headers. I knew it had been taken down, but too late for any action.

Link to comment
Share on other sites

  • Corsair Employee
Please try the 1.05 F/W. that I just posted the other day but if it will not flash then please use the link on the left and request an RMA and we will be happy to replace it. Please make sure that you follow the steps to flash the firmware listed in the sticky post at the top.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...