Jump to content
Corsair Community

SSD not recognized after computer reset


Recommended Posts

Dear all,


I've bought a Corsair Neutron GTX on BestBuy three weeks ago.

It was promptly delivered to my uncle's house in California and then brought to Brazil, where I live, by him - one week later. Please not it did not pass through any kind of magnetic scanner, he's the pilot so... basically no issues.


The only problem was on the connector of my Neutron GTX - It seemed like it had a crack in the middle of the two connectors, power & sata, in its PCB. But it was only something on the plastic though: when he arrived, I've got my new rig set up, as computer specs on my profile, and everything went just fine.


The computer was blazing fast, solid performance, with Windows 8 Pro x64 tweaked it could boot in about 7 seconds. I used it for five days when...


On Saturday evening, I was Photoshopping a bit and the computer hanged after loading a resource. As I needed to install some new fan's on my case (CM Storm Trooper, by the way, not in the specs) I just decided to turn the computer off by holding the power button.


Installed the fans, the fan controller, tested it and everything was working as expected. Except for the... SSD.

It was not anymore recognized in BIOS from that moment on. I've tried to reset the computer but still no luck. I've tried connecting it to another computer:

The computer hangs whenever I connect the SSD. If connected before post, post hangs. If connected when already on Win 7 x64, computer hangs - tried SATA hotswap. Oh, one thing to notice here is that the other computer does not seem to have any configuration related to AHCI on it's BIOS so I'm still trying to get a bootable Win HD to my new rig and try there, so that it might get detected...



Anyway, I'm afraid I could never RMA this guy because of the little crack it has between the connectors, they'll say it's faulty (?)... Now you'll say ok just send it back to BestBuy as faulty... well that costs me about $80, and if they do not accept the SSD, $80 to get back here and faulty... Not worth it?


Does anyone have any idea on what I could do here in order to get it working? Theories, facts, anything accepted, lol


Thanks a lot in advance,





PS: Or even if Corsair has global warranty / support so that I could try to get it fixed here in Brazil?

Link to comment
Share on other sites

Sure, Toasted, that'd not be a problem. As soon as I get home I'll post it in here.

But, anyway, I don't really think the issue would be with the connector... And even if it seems that I should RMA it, I almost bet they'd say it's my fault even though...


Oh well, lets stop presuming/assuming stuff. I'll post it later.


Link to comment
Share on other sites

Toasted, sorry for the repost.


Images of the ssd follow below. Please note the voided stickers: When the drive stopped working, I noticed that when I took it off to replug in another computer, there was a 'noisy' thing inside. Guess what?

They were the pieces of this broken black thing in the connectors. Yeah, i might have done something stupid though... but I kept those with me (the broken things)






Anyway, as those are voided, no RMA or whatever else can be done I guess.. even though I guarantee that if they tested the unit they'd see it's in this 'stuck' mode or whatever you call it...


Does any other way to revive this thing exist? Something like the 'power unit (no sata connection) for 30 mins, turn off unplug cable for 30 seconds...' or hot swapping?


Thank you very much in advance,



Link to comment
Share on other sites

  • 4 weeks later...

Dear Synthohol,


Have not tried to hot plug it for about 20 days yet. Should I try again, do you think something might have changed?


Thanks a lot!


PS: And yeah, i've thought the broken part was maybe damaging or causing the malfunction... stupid me?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...