Jump to content
Corsair Community

Recommended Posts

Yes i know there are a couple of threads about the k90 but none of the "solutions" worked for me..


So i bought my k90 like 4 hours ago, i plugged it in and it worked, then i wanted to update it with the "k90 firmware update" from the official website. After that nothing works my keyboard doesnt light up and its not recognized by ANY computers ( tried 3 windows and one mac) :(

I tryed a lot of things from the forums but nothing worked for me..


System Specs:

Mobo: Asus Sabertooth Z77

CPU: Intel Core i5 3570k

GPU: Asus GTX680 Direct CU II

Power supply: Corsair AX850


i think those are the important ones :)


and yes i already reinstalled the USB and chipset Drivers didnt do anything.


Thanks alot :)

Link to comment
Share on other sites


A couple minutes ago something strange happened.. i was playing around with the drivers( reinstalled and uninstalled unplugged etc.) and when i a bit later looked at the keyboard there where 3 keys glowing "MR" "M2" and M3" no keys worked they were just glowing.. i unplugged and connected it again and now nothing works.. really strange :confused:


i hope someone can hope me as fast as possible.. i cant play crysis with a DELL keyboard :(:

Link to comment
Share on other sites

thank you for your time but unfortanely my keyboard doesnt show up as KBD BOOT LOADER and NO Keys work.. i just tried it on the "unknown device" or something.. and after a couple of hours i could get it to recognize it as "Corsair gaming keyboard but i could not get it to work :[pouts: i hope my seller can replace it because i dont want to wait months for the keyboard.. i mean its ****ing brand new and doesnt work.. its like the h100 i had.. i think ill stay away from corsair products in the future... well except for ram ;):



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...