Jump to content
Corsair Community

More M60 problems


Recommended Posts

This is my third M60 now, and while this doesn't have the rattling middle mouse button as bad as the others, this one has now developed a problem in which the mouse will stop tracking. The buttons all continue to work, but it won't start tracking until I unplug the USB cord and plug it back in. I can use the same port or a different one.

It was only happening on my home computer but now it's happening at my work computers also. I've tested it on the following computers:


Alienware M17x R1 laptop

4 Desktops, (2 Windows 7 64bit, 1 Windows 7 32bit, 1 Windows XP)


They have all exhibited this behaviour.

Do I need to RMA or should I just not bother and go back to Logitech? I'm so disheartened with this product, it's amazing, but this has been an ongoing headache.

Link to comment
Share on other sites

Things I've done:


Reflashed firmware several times.

Deleted profiles on mice and reset default profile.

Changed DPI, Lift height, Poll Rate.

Used every single USB port on all machines.

Tried with software installed and without software installed.

Tried in safe mode, on 2 computers, but because the issue sometimes takes forever to present itself, I can't waste any more time on this.

Link to comment
Share on other sites

This mouse is basically unusable, I just finished playing a game of QuakeLive where it stopped tracking 5 times in 2 rounds. That's 5 times in less then 2 minutes! And now my mouse wheel is squeaking when I scroll it WTF?!?!

I don't think I'll ever be recommending a Corsair product to anyone, ever again.

Link to comment
Share on other sites

It sounds like the M60 is faulty.


Request an RMA to replace the M60. If this has been your 3rd replacement via Corsair, i'd suggest you contact customer service via phone and tell them that your third replacement unit is faulty.


You can call them via Skype using their Toll-free number.

Link to comment
Share on other sites

I think I fixed the squeaking mouse wheel problem, there was some hair or something of similar consistency wrapped around the bar on the scroll wheel. After removing that the wheel stops squeaking when scrolling.


However the tracking issue persists.


Ramguy, I was supposed to get a call from customer service in regards to the Advanced RMA, but I never got the call. More then likely they were just busy with other orders and couldn't get to mine on time. I'll just wait til Monday.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...