Jump to content
Corsair Community

Link not detecting and RAD screwholes..


Recommended Posts

Hi guys


I had posted a thread in the link section regarding the detection issue but thought might give it a shot in this section as well!! I have three issues in total with the H80i (replaced already on RMA. Firmware v1.0.5).


1. When I use the link cable that comes in the packaging, random things happens. Sometimes link is not detected as a whole. Sometimes, the Hydro series not detected. At times both gets detected but sensor doesn't show any devices connected to link as well any values, like temps, RPM, pump, et al. I have tried the device manager hardware ID technique, also tried removing all the hubs but nothing helps. As a last resort I tried a mini to USB cable and that did the trick. So I have set all the desired values and it works perfectly.


2. RAD Screw Holes threads off easily. I had 3 holes became loose did an RMA and now the new one seems to be doing the same. ATM, I have just got it right, but one more dismantle and 100% the screws ain't fitting. Only way to fix this is I can only use on fan towards the CPU and fix just the RAD to the case. Is there a big temp difference between one fan (push exhaust) and two fans push-pull??


3. The corsair link dashboard custom fan profile doesn't seems to work. I have set four fans according to the following values: temps 30, 49, 59, 69, 70 and rpms are 600, 800, 900, 1000, 1850 respectively. But when I do a prime test, the fan doesn't budge from 600-700 RPM!!! Is this a common issue??


Sorry make the post too long, guys!

Link to comment
Share on other sites

I dont have an answer for 1 and 2 but for the fans not going faster, I'm pretty sure by default they are following the H80i liquid temperature not the cpu. To change it click on the fan and change the group from H80i Temp to CPU Temp.
Link to comment
Share on other sites

1. Latest BIOS and chipset drivers?

2. If the screws aren't fitting on properly, contact customer service via phone and tell them that your replacement unit also has loose threads.

3. Are you using the stock fans that come with the cooler?

Are the fans grouped to the coolant temp or the CPU temp?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...