Jump to content
Corsair Community

k90 and m90 issues


Recommended Posts



im making a new thread for my problem, as i haven't seen any theads about it yet. i have a quite strange problem with my keyboard. as you may have noticed, i am not using any captials in my sentences, because i simply can't by using shift.

basicly my problem is that i cant hold any of my function keys like shift, ctrl, alt or even delete. -holding delete just deletes one letter-

so if i want to use a capital for my words, open a new tab with ctrl t or whatever, i cant do it.


it all happened when i updated my corsair software and firmware -both my m90 and k90-, and i have tried several things to restore this. i have tried reflashing my keyboard, restarting pc -on startup i can actually use shift for a captial in my pc password-, replugging keyboard, deactivating hardware playback and reactivating it.


itj ust basicly makes my life harder as i cant communicate properly and cant use my browser properly. i havent tried out gaming yet, ill try this after this post. i have played a match of league of legends this morning with the problems and it worked. but it has gotten kinda worse.


hope i made it as clear as possible.


as for my m90 problem. i have found threads about this. it involves my mouse wheel problem. its not as bad that it will scroll down a page on touch, but if i scroll top, sometimes ill get quick downscroll between my up scrolls. nothing major and it doesnt bother me that much.



ive just started up my league of legends client. seems that i have no trouble using shift etc. in the ingame chat. about to run a test game, see how that goes. the function keys seem to also work in teamspeak. so far its not woking in either;

- skype

- chrome

- firefox

- notepad

- windows explorer -e.g. windows key r, searching in start menu-



of course in game the keys work. tested a few games and they all 'read' the shift and ctrl in a normal way -smart cast in lol, sprint with shift in shooters-. is there anyone out there who can help me/ im not sure this is pure hardware, could be some system settings. mouse is also working just fine



the problem could be defined as keys not being sticky. some threads complain about sticky keys, while my keys are just never sticky. it goes for al keys. if i hold for example the letter 'a' i just stay 1 letter, no matter how long i hold. never sticking keys sucks. please help1



Problem seems resolved! I have completly deleted all the software from corsair, did a FW update on both devices then reinstalled every software required for M90 and K90. Seems to work now. Will post update if problem remains.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...