Jump to content
Corsair Community

H100i - corsair link 2 crashes, no fan speed controll and more...


Recommended Posts

Hello to all


First of all I'd like to say hello, it's my first post on this forum :)


I bought and installed H100i and Corsair Link 2 software on my old PC just to test it before motherboard/cpu/memory upgrade.

It all worked fine, temperature display, H100i control, hard drives and gpu temperature display.

Last weekend I upgraded to Gigabyte X79 - UD3 with i7 3820 and 16GB 4 channel corsair RAM

I tried to open Corsair Link 2 and it crashed straight away, I tried to reinstall it few times, swap USB header on the board - still the same. Then I tried to run it in winxp sp2 compatibility mode and it opens ok, but I don't have any control on fans speed and no hard drives temperatures are displayed any more. When I try to minimize it it crashes again.

I've hot win7 64bit ultimate and I didn't change anything within it, just replaced PC components (all hard drives remained unchanged). Just wanted to add that my system drive is 120 GB Corsair Neutron SSD.

What do you think?

Link to comment
Share on other sites

Having the same issue with 2 machine now. Problem seems worse on the machine I have been trying it on this time. I am basically scrapping it to buy something else. Going to end up sticking it in a basic workstation at the office. It does work without any of the link software. I have no real control and its no good for benching and gaming because I don't trust it. When the link is installed etc it detects everything. One of my friends is an IT director at a software development company and he checked some errors etc and said the drivers seems to be asking for resources which aren't there and creating some sort of critical error. I am pretty vague about it because he is miles beyond my technical competence so I didnt rightly understand exactly what he was saying but take it he was saying there is a driver problem.


He said its unlike to work as I have my machine setup so I am better off ripping it out and replacing it.

Machine its in right now although I am planning to remove it this weekend. I keep testing it and trying to resolve but its not happening.


Rampage IV extreme X79

i7 3930K

16 GB Gskill 2400MHZ

1 Sata III Mushkin SSD

2 x WD Caviar 2 TB

3 x MSI GTX680

1350 W PSU

Latest BIOS on BIOS one. A revision back on BIOS2

Latest chipset drivers etc.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...