Jump to content
Corsair Community

Force CSSD-F120GB2 Dead?


Recommended Posts

I believe the drive just gave up the ghost. I was reading news yesterday morning, and everything just stopped. I rebooted, and although the BIOS sees the drive, I can't get into Windows. I've tried windows recover options, but nothing will get started. Here is the specs:


Drive 1: Corsair Force CSSD-F120GB2

Drive 2: WD Black 1TB

8GB mem - PC2-800

Gigabyte GA-MA785GM-US2H

Windows 8 on SSD, data on 1tb


I don't get any error messages, as it just halts loading windows on a black screen, no text, no windows icons, no nothing. I've tried safe mode, I've tried the system recover, the system restore, the disc scans, and nothing shows up past 4% system recovery.


Have I missed a Corsair drive utility somewhere? Unless someone has a brilliant idea, I'm going to pull the drive and put it into another system to do a quick scan for any data files I may have misplaced and RMA this.



Scott Barrett

Link to comment
Share on other sites

Yes, ahci is enabled.


This drive has been in the system for 2 years (almost to the day), working just fine. Then Saturday morning while reading the news, the computer froze. After rebooting, it won't start again. I've tried the drive in two other systems and in both cases, after a reboot or two, it will show up, I can see directories in explorer, then after about 2 minutes total run time, I can't access the drive any more, then the system freezes.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...