Jump to content
Corsair Community

H80 Problem :(


Recommended Posts

Hello everyone, I' am new here,unfortunately I ran into a little issue today.


So I would like to be specific as possible, I used to own a Phenom II processor and until today I got me a new FX 8350 processor,so I took out my H80 unit took out old processor and put in new one with new thermal paste and put the H80 back in place just like I did the first time.


I plugged in the fans into the pump, plugged the pump into the molex power supply connector,and plugged the pump into the CPU FAN slot in the motherboard.


I turn on the computer only to find out my H80 does not work,to be specific the fans nor the pump turn on, you know the pump has the 3 setting lights, well none of them work,so I immediately turn the computer off because I am afraid of burning the CPU and I got it today and it won't get covered in warranty if I fry it.


So my questions is,is my unit dead? I mean before I took it off, I turned on the computer to check something,then after that it didn't work, I made sure it was in place, I made sure the fans were plugged into the pump, the molex connection was hooked to the power supply connectors, I even changed to a diff connector and nothing, I tried diff cpu fan connector,nothing.


I hope my unit did not just die on me out of nowhere, I bought the unit back on October 1st 2012 so it is just a few months old, and it worked flawlessly until today. Right now I am using my old heatsink but I mean once you use Corsair H80 Liquid Cooling you can't go back to air cooling!


I was hoping to OC my new 8350 but now with air I don't think I will be able to do this. Are there any other suggestions I could try? I doubt I overlooked something, I spent 90 minutes trying, I even used a different fan to see if it was the fans,but like I said it worked before I even started.


Please,any help is greatly appreciated, I hope that my unit is not dead,and there is another way around this.


PS : I did use a wrist strap and made sure I was grounded before,during,and after the installation.


update : So i went back and i brabbed the h80, and i plugged it into the molex connector while having it my hand,the block and the radiator, and i felt vibrating in the hose and block,meaning it turns on,but what doesnt turn on is the lights on the block,the lights for the fan speeds. Any suggestions?

Link to comment
Share on other sites

try another usb port,also look at the pins on the molex connector to insure their fitting properly.if it just worked then it must be in a connection point.,specifically the molex plug.

also the m/b has overheating protection so it will shut down before damage is done

Link to comment
Share on other sites

what do you mean by try another usb port, and I did try using other molex connectors, I do not know at this point what could have caused it to stop working suddenly, i doubt it was static because I was grounded with my strap.


Ok so I tried another molex connector, 3 different ones actually,same result, I feel vibration in the hose and block,but nothing else,the lights do not come on, and I plug in one of the fans to the block and it does not power on,at this point I give up, I guess my H80 is dead and there is nothing I can do about it.


I did ground myself and I find it very odd that it stopped working out of nowhere,replacing the cpu took me 5 minutes. Very weird.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...