Jump to content
Corsair Community

Vengeance 2000 - No Sound, but connected


Recommended Posts

Hi Folks,


I purchased the Vengeance 2000 recently (2 weeks ago). All was working fine, playing games and so on.


I thought I had an issue connecting to Mumble, so I restarted my machine. I made no changes to any settings prior to rebooting, nor did windows (Vista 64bit) do any updates of any kind. Upon reboot, I had no sound, at all nothing.


To get the sound back (which has been unsuccesful) i have tried the following


-Uninstall all audio drivers of all types including realtek MB Drivers and reinstall MB drivers and let windows pick the headset up automatically

- Tested the dongle on another machine, same issue

- Resynced the headset with the dongle via the method using the paperclip and the recessed button on the dongle.

- Made sure that the Headset is the default device in the sound options in control panel.

- I have also let the device full discharge and I have then recharged it fully, and then tried to reconnect the headset with the dongle using the recessed button method.


Not entirely sure where to go from here.


The current state of things as they stand:


-Solid blue light from the dongle.

-Intermittent light from the headset, blips blue every 4-5 seconds.

-Fully changed.

-No driver error codes under device manager for any audio driver.

-if I blow air into the microphone, I do hear the loopback.


I dont know where to go next


- Frustrated Network Engineer :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...