Jump to content
Corsair Community

4G Corsair USB Stick 4GB Survivor now its only 2G


Recommended Posts

I have a Corsair Survivor CMFUSBSRVR-4GB / 4GB USB 2.0 Ultra Rugged Water Resistant Flash Drive after using it for a while satisfactorily I put it to one side and forgot about in a draw at the side of my desk. Now when I have come to use it again it is only showing it has a capacity of 2G.


I have tried a reformat of it and that didn’t make the missing 2G return then I tried in Linux

dd if=/dev/zero of=/dev/sdd

hoping that would solve it by wiping it clean but it is still showing up as a 2G only.


This is the output of fdisk -l



Disk /dev/sdd: 2015 MB, 2015489024 bytes

63 heads, 62 sectors/track, 1007 cylinders, total 3936502 sectors

Units = sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 512 bytes

I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk identifier: 0x6f20736b


Can this be fixed somehow or do I need to ask for an RMA or better still can I take it back the the computer store I bought it from Scan Computers UK? the pendrive is about 3 to 4 years old but rarely used.



Link to comment
Share on other sites

This isn't an SD card its a Corsair pendrive, the utility you seem to have pointed me to, although you didnt give it a name appears to be for SD cards.


However I did try it, it looks like it has a resize option but when I enabled it the resize panel was still greyed out. Nevertheless I tried to reformat my pendrive with the SD Formatter 4.0 for SD/SDHC/SDXC. The formatter program came back with a error saying my SD card was write protected.


Please advise on what to do next please? Thanks

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...