Jump to content
Corsair Community

Firmware update fails CSSD-F60GB2/RF2


Recommended Posts

Having an issue updating the firmware on CSSD-F60GB2/RF2


No matter what I do, the firmware loading process either locks up the machine or reboots it after approximately 1 minute, but the firmware version never changes.


I think I'm doing everything correctly, but open to hearing if there's some obvious mistake on my part.


This drive is a spare that's been on the shelf for a year and is now needed. As always, I went to install current firmware before using it.


I have a couple workstations set up just to do firmware upgrades and such, they are clean and easy to toggle different operating systems and BIOS settings like AHCI. I've updated many SSD drives before from a wide array of manufacturers. Not saying I'm expert, but just that I'm not new to doing firmware upgrades.


I've tried Vista, Vista Ultimate, Windows 7 and Windows 8, and have been using what I believe is the correct tool, the 2.4 firmware package in this forum.


The F60 drive shows up reliably in every instance, displaying 2.0 firmware. The 2.4 pkg file loads cleanly within about a second or two.


After confirming Yes that the drive contents could be lost, the system will either lock up hard or will reboot after approximately 60 seconds.


The F60 drive is a secondary in AHCI mode, contains nothing. I even tried initializing it, no difference. Then tried formatting, no difference.


Is it an issue the /RF2 designation? Is 2.4 definitely the appropriate firmware?


As mentioned by Yellowbeard, there is no longer an alternate firmware .pkg in the tool to try.

Link to comment
Share on other sites

Some systems are not capable of this update. Users that have this issue are encouraged to find an alternative system for updating the drive. Users that cannot manually update are encouraged to file an RMA. Note that an RMA for update to firmware 2.4 will result in complete erasure of the drive. RMA LINK.


If this is the last resort, can someone clarify what happens here?


Does you send the drive in and Corsair then upgrades it and sends it back?


Or do they send you a different drive with newer firmware?


The drive has no data to preserve, but I'm trying to avoid costs and delays.


Also concerned about sending a fresh drive with no cycles and possibly receiving one back that has a lot of prior usage.

Link to comment
Share on other sites

I think the RF next to it means its a refurbished unit.


Are you experiencing any problems with the drive?

Latest BIOS and chipset drivers?

Post your system specs.


As mentioned, the drive is unused. As such, it's exhibiting no problems. It's always recognized instantly by the firmware tool. I even initialized and formatted it to see if that would help. Yes, latest BIOS and drivers, and I have updated firmware on many other devices using these workstations without incident.

Link to comment
Share on other sites

I don't see the need to update the firmware?


Try it on another computer and see if the update works.


As mentioned, I have tried it on several reliable workstations with same results.


Corsair acknowledges this situation and they further say there is an RMA process.


As to why users should update, it's considered best practice to keep firmwares the same and current for drives across a system or array.


You don't want to have drives in use with mismatched firmware. And all the firmware updates including Corsair state there is a risk of losing data during the update, which of course you'd want to prevent. Also, if it can't update the 2.4 firmware, who is to say it will accept 2.5 or later firmware?


Is there some obvious mistake I'm making on my end? Is the 5.0.3 firmware possibly the right one for this? It references the GB2B and GB2B R/F which is suspiciously close match to the model number.


I do appreciate you helping, but was expecting someone from Corsair would be here providing official support.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...