Jump to content
Corsair Community

CM2X1024-6400C4 module errors


Recommended Posts

Hi everyone,


I've had steadily increasing BSOD failures in Win 7 for a few months now, which progressed to being virtually daily, and then it happened in the middle of something critical yesterday, which finally prompted me to track it down! Reading on this and other forums helped me to track down the likely problem to one of my memory modules.


I have the following modules installed, 2 bought in Nov 2007, and then 2 in Apr 2008.

CM2x1024-6400C4 ver 6.2

CM2x1024-6400C4 ver 6.2

CM2x1024-6400C4 ver 2.1

CM2x1024-6400C4 ver 2.1 ---> faulty module


I tested each one individually using memtest-86, and consistently found errors with the one marked. The others had no problems. I am now running just the other 3 modules (3GB) (which to be honest I wasn't expecting to work). I have never changed my memory settings away from automatic, and never embarked on any overclocking type activities.


I have read lots about changing settings and voltages and all sorts of ideas for memory not performing well/causing errors. Or do I just accept that this module has now failed? Looking at my emails, I had to RMA it the first time around (DOA).

My order confirmation from ebuyer does say that it has a lifetime warranty - does this stand still!? If yes, should I return it to ebuyer or Corsair? And should I return it with the other half of the pair it was sold as even though that one's fine? I don't think the same memory module can be supplied now, so presumably I'd have to replace the pair as it'd be something different?


Thanks for any help/suggestions!


Link to comment
Share on other sites

Thanks for the quick reply.


I have found these two links:

http://forum.corsair.com/forums/showthread.php?t=52351 (older)

http://forum.corsair.com/v3/showthread.php?t=81034 (newer)


Just to clarify, are you asking me to change settings to what it says on the older (1st) thread, under the heading of "Testing parameters for Twinx/XMS2-6400C4"? If you can confirm that page is what I'm trying to do, that'd be great! Thanks.

Link to comment
Share on other sites

  • Corsair Employees

There is only one profile for this part does not matter which version of the modules. And when you mix two sets you may have to run the memory frequency at DDR667.

Testing parameters for Twinx/XMS2-6400C4:

Twin2x2048-6400C4 Data Sheet


Motherboard make and model: Asus P5WD2 or M2N32-SLI Premium/Deluxe

Each pair is tested and packaged together using the following settings:

AI Over Clock Tuner: Manual

CPU External Frequency: Manually set to 200MHz

DDR2 SDRAM Clock: Manually set to 800MHz

PCI Express Freq: Auto

PCI Freq: 33.33

Performance Mode: Standard

DRAM Timing Selectable: Manual

SDRAM CAS Latency: 4T

SDRAM RAS to CAS Delay (tRCD): 4T

SDRAM Row Precharge (tRP): 4T

SDRAM Active to Precharge Delay (tRAS): 12T

SDRAM Write Recovery Time: 5

Write to Precharge Delay: 15 (If it's Listed)

Command Rate: 2T

DDR2 SDRAM Voltage: 2.1

Advanced voltage control

CPU Vcore offset:_Disabled

DDR2 Termination: 0.5x

CPU to NB HT:____1.200V

NB to SB HT:_____AUTO



SB Standby core:_+1.500V


Output driver control





Chipset Core Voltage: Auto

All other settings are motherboard defaults.

Maximum DDR2 recommended VDIMM: 2.1 Volts

Link to comment
Share on other sites

Ok, all settings put into bios. Same results, errors quickly with all 4 in place. Now removed the offending one, and testing the other 3 with the new settings - got through the first pass with no errors. Having already worked out that it's not to do with any particular slot, I don't think it adds anything to start retesting them individually again.


so, why do you think I need to replace all 4 rather than just the matched pair? And if that 's the case, will they therefore all be replaced on corsair's rma?


thanks for helping!

Link to comment
Share on other sites

  • 4 weeks later...



I received my replacement ram today: TWIN2X4096-6400C5DHX


It seems to have broken my computer! Swapped old memory in for new memory, same way I always would. Bios got to checking memory 4gb, or whatever it exactly says, then froze. Now it won't even start to boot/post. Sequence of events on my computer is that when powered up, graphics card fan goes at full speed for about 1-2 secs, then slows down, then display comes on and usual bios messages. What is happening now is it just gets stuck at the first stage with the graphics fan on full, and never any progress or display from there. I have tried original working ram setup again, single ram module of new, single ram module of old, same result. I have also tried connecting the cmos reset jumper for 10 seconds with power disconnected, and then tried cmos battery out for 25 minutes. Still same. No bios beeps or anything.


Any suggestions what might have happened, what I can try? Or has the new corsair memory broken my motherboard!? I don't have a second rig to try the ram in, and to be honest I think I'd be pretty scared to!

Link to comment
Share on other sites

  • Corsair Employees
The memory modules shouldn't be the cause of the problems you're having as they don't provide power to the motherboard (its the other way around). If you're having issues with POST though, try to do a hard reset to the motherboard by pulling the CMOS battery out and reseating it.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...