Jump to content
Corsair Community

Corsair AF fans and link


Recommended Posts

I have grown tired of my non-corsair fans dying on the link controller so I decided to order corsair fans. Can anyone confirm whether or not the AF fans work with link or not? If not, could you please recommend fans that are known to work? I am looking for 120mm, good CFM. Not so worried about noise if I can vary the speed properly. I don't mind if they are somewhat noisy when I game. I turn the sound up anyway.




Thanks in advance

Link to comment
Share on other sites

I have 2.1.7. I selected the 1.2.5 firmware. I think it might be because I have multiple nodes, not sure.


I have some new fans coming this weekend and plan to try again. I will unplug everything (lighting nodes, and other cooling nodes) and try with just one connected.

Link to comment
Share on other sites

Thank, but no luck.


I removed 2.1.7, deleted the directory and rebooted.


No matter what I try, it won't recognize the node. The don't show in corsair link either.


Just to be sure, I did the following...

1) Shutdown and Unplugged the commander for 5 minutes from the USB port.

2) Unplugged all of the system links except for the node that I was trying to flash.

3) Tried a different port on the commander for the link.

4) Tried both cooling nodes separately.

5) Removed the ax1200 dongle from the other USB header.


If I leave the window open on the bootloader, it will occasionally flash something other than "unidentified node". It will sometimes say "cooling node" for a second and then go back. It will also sometimes say "Airflow pro".


Bootloader screen attached.


Link to comment
Share on other sites

Ha! I beat it. :D:


This is really weird, but whatever. :confused:


Everytime I tried to flash the nodes, they gave the unidentified node error. I think this was because I could never get it to work from inside Link. When I clicked "update firmware" from link, it would close and never launch bootloader. I would then run bootloader from the link folder.


Out of frustration, I kept trying different methods. Here is what I had to do to get it to work.


Select a node in link. ( any seems to be fine, lighting or cooling )

Click "update firmware".


(tricky part)


It will pop up asking if you want to save the profile. You must click "cancel". This will launch the bootloader. If you click "yes" or "no", it just closes link.


The nodes still said "unidentified", but I knew what channel they were and selected that. They updated to 1.2.5. :D: :!::!::!::!::!::!:



They then showed up again in the link software and I was able to set the fan profiles and everything. :D:


Thanks for your help. :biggrin:

Link to comment
Share on other sites

Just an update:


I lost one fan on one node and two on the other this weekend. It happened at the same time that the h100 fans spun up to max.


I used the reset procedure for the h100 and flashed the cooling nodes again ( like above) and they all recovered to normal.


It would be nice to not have to re-flash the hardware periodically.

Link to comment
Share on other sites

Hope it works for you bud, its crazy what steps we have to do to get it working.


Thanks :sunglasse


I installed the h100i this weekend. <knock on wood>. So far so good.


One of the corsair AF fans started buzzing a couple days ago and I had to put in on max RPM in link to get it to stop. A little more "spit and bailing wire" and the system should be all worked out. :confused::biggrin:

Link to comment
Share on other sites

I have the same problem - seems to be a lot of that going around - it has to do with the cooling node firmware 1.2.5. They're working on a fix.


That's good to know, thanks. :sunglasse


It's not too bad. It is only slightly audible at max rpm so I don't mind.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...