Jump to content
Corsair Community

USB Device Not Recognized (Windows 8)


Recommended Posts

I have a CMFVY3S-32GB Corsair Voyager USB 3.0. It works perfectly fine on five different PC's, but as of this morning, whenever I put it into my one and only Windows 8 Lenovo laptop I get the USB Device Not Recognized error. I've tried it in three other PC's today and it doesn't seem to have any trouble, but on my W8 laptop it simply won't function.


I thought it was the laptop for a moment, but I tried a Patriot Rage XT (64GB USB 3.0 Flash Drive) and a WD Passport (1TB Spin drive, USB 3.0) without any troubles. Are there drivers for the corsair, or is there some basic step I should try? The search on this forum pulls up 9000 posts, none of which are related to my problem.

Link to comment
Share on other sites

Under Device manager it says:


This device cannot start. (Code 10)

The USB set SEL request failed.


The latest bios was a good suggestion, but my coworker has the exact same laptop and it works fine on his. The difference is that he was smart enough to not upgrade from Windows 7 to Windows 8.


I think I updated the BIOS right before upgrading the OS, but I am going to check it today just in case.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...