Jump to content
Corsair Community

Corsair Link Dashboard not showing the H80i


Recommended Posts

Hi Guys,


I don't know what's wrong here but my corsair link dashboard v2 doesn't give me any information regarding the WHOLE cooler itself.

here's a screenshot:



Also upon checking on the Devices list sometimes the Corsair Hydro Series device gets picked and sometimes it doesn't get listed.




can anybody shed some light here.



Link to comment
Share on other sites



I don't have a thread about the Hydro Series i coolers, only the LINK kits.


Corsair LINK threads i made

Corsair Link: Links to everything!

Link kit not detected in 2.X.X?

Updating firmware on LINK 2.X.X




Is the cooler detected in Device Manager?

Check the connection from the motherboard and the block.

Try an older version of the dashboard e.g. 2.1.7 and see if it's detected.


BTW, the images are super big.

Link to comment
Share on other sites

Thanks guys for the links and tips!! Much appreciated!! Sorry was tied up at work and life thing so couldn't reply u guys!! I tried literally everything as per links!!


First uninstalled windows and reinstalled it - no good!! Shows the same screen. Under device manager it shows either unknown device or a yellow triangle!!

I've tried starting from just Keyboard (K90) and mouse (G9x), reinstall windows, then switching the USB 2.0 ports on the motherboard (pins and the rear panel USB slots), and multiple reboots, shutdowns and what not!!!


Whilst Trying to get this issue fixed; I've come up with another issue (lol)..!! The screws (2) don't tighten anymore....!!! So I'll be doing an RMA altogether!! Just off topic do I just send the AIO H80i cooler or do I need to send everything with the box??? Region I live is Australia!!


Thx for the help guys, once again!!

Link to comment
Share on other sites

I got it replaced...!! thanks guys...! and this time around the light seems to be working on the LED! So that looks like a first sign of progress....coz the last time one I had wouldn't light up a bloody thing....!


but after a couple of restarts I started getting the unknown device thing on the device manager again....!!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...