Jump to content
Corsair Community

Changed from ddr2 to ddr3 ram motherboard, ssd went from 7.4 back to 5.9 WEI


Recommended Posts

(I though I posted this somewhere, but after computer restart I lost link to thread, sorry if this is a dupe, my luck really has turned for the worse past days).


Hello, I decided to upgrade my computer, it was previously running on the old motherboard that supports DDR2 RAM(which only gave me about 200Mbps(I think, didnt verify by bench~) read/write), I had my Corsair Force 3 SSD drive which I kept and still using on the new motherboard(990FX R2.0).


The reason I heard that the SSD was so slow was because of this old motherboard, if I could get a new one that supports etc DDR3 RAM and this sata3 thingy, then I would be able to utilize something similar to the promised 500+ read/write of my SSD drive.


On my old motherboard, I had 7.4 in windows experience index for SSD disk performance.



However now when I upgraded to this new motherboard which should support my SSD to its fullest potential, the ssd speed dropped down to aprox 80/40 Mbps speed/write


And the WEI dropped down to 5.9.



What is going on? Googling does not seem to help me, they tell me to verify that it is AHCI, which it has always been in OS registry, and it configured automatically to AHCI in the BIOS.





(In first boot of the new motherboard, OS crashed and I had to manually enter the BIOS, and boot the SSD drive to start windows for some reason).


I have connected off the regular SATA spindisk to verify that the only connected hard drive to computer is the SSD, and I still get 5.9 WEI


Updating SSD firmware:

Tried to download corsair force 3 SSD latest firmware, extracted the 120GB version which fits my disk. (even tho I only seem to be able to use aprox 94GB of it).


Selected update Formware, entered the 120GB folder, selected the file that was related to my signature ending code, and I got this image:


And yes, I have tried to run this program as administrator, does not help at all.



So yeah, no luck here. :[


I am complete noob in this field, all this failed knowledge have I learned past days just googling around. Now I am frustrated and desperate enough to do my best to fill you in and hopefully gain a chance to actually fix this problem.


Any reply is highly appreciated since I really want to get my disk running at its apropriate speed, thanks!

Link to comment
Share on other sites

Here it is:


And im pretty clueless to what these results mean. :|


Im not using WEI for accurate benchmarking, but to determine wether windows is understanding my components like it should. If it does not then there should be some sort of problem thats causing windows from utilizing the component to its fullest potential?

Link to comment
Share on other sites

  • Corsair Employee

You are not running in AHCI mode that is why it will not let you update the firmware.

And the issue is likely because you changed MB's and did not secure erase with Parted Magic to the drive and do a fresh install of the O.S. on this system.

I am just guessing of course, so how far off am I so far?

Link to comment
Share on other sites

AHCI is enabled in the BIOS, fourth Screenshot.

2nd one is probably true.


Based on the second screenshot, You are using the AMD AHCI drivers? If so, uninstall it and let Windows install the MSAHCI driver then try the FW update again.


If it does update successfully, i'd suggest you secure erase the drive with Parted magic and reinstall Windows as it should fix the alignment issue.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...