Jump to content
Corsair Community

H100i Software problems


uninfallible

Recommended Posts

This is my second H100i and it is not showing when I use the Corsair Link dashboard software. Both entries are in my device manager (HID-Compliant Device and USB-Input Device) and when I first installed the Corsair it quickly flashed a driver install box which I can only assume was the H100i.

 

Now, when I have the software open It shows literally everything inside my PC except the H100i. I can't change the fan speed, LED or anything else. There is not even an icon for the H100i and I have tried messing with the options etc. Is there is fix for this or not? This is the 2nd one that has done this and the last one Corsair phone support advised me to RMA it only to receive another with the exact same issue...

 

Any help would be much appreciated, thanks.

Link to comment
Share on other sites

What version of the Link software are you running?

 

In the Link software, under 'Options/Devices is a 'Corsair Hydro USB' listed?

 

I'm thinking your cooler is still on the old firmware. If you have CorsairLink 2.2.0 it won't show. You'll need to uninstall it clearing out all the files/settings in 'C:\Program Files (x86)\Corsair' and 'C:\Users\{username}\AppData\Roaming\Corsair', reboot and install CorsairLink 2.1.7.

Link to comment
Share on other sites

No firmware update available atm. Even if you find it elsewhere it's not advisable to flash

 

The usb problem. Try moving your other usb stuff around. Motherboards have several usb hubs built in. I believe it's best to have these coolers on their own hub. There's no indication of this on the mobo, so it's a case of 'suck it and see' I'm afraid.

 

You installed 2.1.7 and proved the unit and the software are working.

 

Catch 22 situation here. When the new firmware is released and you flash it you'll need at least CorsairLink 2.2.0 to control the fans. But you'll need to keep 2.1.7 for now to do the flash.

 

My suggestion for now is to connect the fans to the sys_fan headers on your mobo and control via software, or a fan controller if you have one.

 

I know it's not ideal, but we have to demonstrate patience on this. The firmware will only be released when it's fully ready (understandable after the last release).

Link to comment
Share on other sites

I have 1.0.4 on here now and I'm not having any issues. The only thing that seems to have changed from when I had the 2,2,0 installed is my video card isnt listed by the exact model, instead of GTX 680 is says Nv Fan and Nv Temp which isn't a problem. I am not having any loud noises from my pump either.

 

The only thing I have noticed is a slight scraping noise when they fans are on Performance setting. I am assuming this is just an issue with the fans not the firmware. If it is, I'll fix it when 1.0.5 comes out using the 2.1.7 dashboard and then update the dashboard to 2.2.0 correct?

Link to comment
Share on other sites

Nv Fan and Nv Temp are completely normal.

 

I'm glad you got away with the flash, was taking a bit of a risk.

 

Could rule out the fans by connecting them to a spare motherboard header temporarily, one at a time.

 

If it is the firmware making this noise Corsair are aware and hopefully will fix it with the next release.

 

You can install 2.2.0 now m8, as you have the 1.0.4 firmware.

 

I still can't believe you did the flash. Ah well, enjoy your cooler ;):

Link to comment
Share on other sites

I tried to flash it with 2.2.0 when it was showing as "USB Pump" or something, not Corsair H100i. It seemed to load and then said failure to load. I then uninstalled/removed program data, CCleaner registry, reboot and when I installed 2.1.7 the 2nd time it is showing the H100i as 1.0.4. Does it ever come as 1.0.4 from the box? I was never able to see the firmware version number until now.
Link to comment
Share on other sites

You got one of the newer ones then (lucky devil), tho they are shipping direct from Corsair now with 1.0.5. It would make sense that they would ship from Corsair with 1.0.4 since it became available as a download. Seems to have taken a while to filter through to the end user. I've yet to buy one that doesn't need updating.

 

Can't see any reason why 2.2.0 didn't see it right. Someone else will pop in and explain that.

Link to comment
Share on other sites

It is weird because it's on the same USB header/controller as before. I hope they release 1.0.5 for dl soon because the fans only make noise when they are controlled through the H100i. How is it possible for the firmware to make the fans scrape? Is it something to do with power delivery/motor noise and not blade/bearing noise?

 

If I replace the fans what's the general consensus on the best part?

Link to comment
Share on other sites

  • Corsair Employees
The noise is coming from the stocks fans, but keep in mind that not all unit are affected by this issue. For those who are, we will be releasing a new set of fans that will address this high pitch and buzzing noise.
Link to comment
Share on other sites

The noise is coming from the stocks fans, but keep in mind that not all unit are affected by this issue. For those who are, we will be releasing a new set of fans that will address this high pitch and buzzing noise.

 

Glad to hear that the source of the high pitch noise has been found.

 

How will we go about acquiring the updated fans?

Link to comment
Share on other sites

The noise is coming from the stocks fans, but keep in mind that not all unit are affected by this issue. For those who are, we will be releasing a new set of fans that will address this high pitch and buzzing noise.

 

So what should we do? Do I have to report rma and you'll send me new fans or what?

Link to comment
Share on other sites

Glad to hear that the source of the high pitch noise has been found.

 

How will we go about acquiring the updated fans?

Once they are released just submit an RMA, but in the comments section explain that you would like to RMA JUST the fans. Should be that easy!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...