Jump to content
Corsair Community

M60: Worked Nicely, updated firmware now broken


Huzzaification

Recommended Posts

Hello, I'm having a issue with the Corsair M60 mouse. Earlier today i bought it, got home plugged it in worked amazingly, every button worked, could go through the dpi's, sniper button lowered the dpi. I was in love with it.

 

After awhile of goofing around i decided to go to Corsairs website to download the program/drivers. Downloaded everything and installed the corsair gaming software for the M60, still worked great, could adjust everything and it worked perfectly. I went back to the downloaded files and noticed that there was a firmware update and decided to do it (I don't know why i did it, i just like keeping things up to date)

 

After the firmware update the mouse was a little slower dpi wise. I tried screwing around with the settings with the lights, dpi, etc, but nothing worked. The software doesn't recognize the mouse anymore. The mouse itself still works like a basic mouse, left click, right click, mouse scroll all works, but the dpi is frozen, the buttons on the side don't work, and the sniper button doesn't either. I tried restarting my PC, along with a few other things and nothings worked, I unplugged the mouse and put the old one back in. But before i decide for sure i don't want this thing anymore i wanted so see if you could help me.

 

So, any help will be so greatly appreciated and thank you in advance, thank you even for just reading all of this...

 

Tl;dr version - Mouse worked great, did the firmware update, now all the extra buttons on the mouse are broken and the software doesn't recognize the M60

Link to comment
Share on other sites

  • 1 month later...
I am having this exact same problem. I just received the mouse today NIB from Amazon, plugged it in, tested all the buttons, etc, it worked great. I updated the firmware to the latest version, installed the Corsair software, and now none of the buttons work (except the left/right click and scroll wheel), Windows will only install the HID-Compliant drivers, not the automatic M60 Corsair driver as it did the first time, etc. This is a huge dissapointment.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...