Jump to content
Corsair Community

HX650 brand new with "birdy" noise...


MultiDoc

Recommended Posts

Hello,

 

I didn't open a new thread since I got the exact same problem posted here, the weird chirping sound/noise from my brand new HX650 (just bought it today and installed it a few hours ago).

 

I suspect it is advisable to proceed with an RMA ?

 

Thanks in advance for your time and help,

 

Nick

 

P.S: just in case I have already used the RMA link and got an email, waiting on Corsair's response

Link to comment
Share on other sites

I didn't open a new thread since I got the exact same problem posted here, the weird chirping sound/noise from my brand new HX650 (just bought it today and installed it a few hours ago).

i would suggest returning it to the place of purchase first. If they are not able to exchange it for you, then i would go ahead and RMA it. But if it's only a couple of hours old that would be the best place to start.

 

If you have any further questions please start your own thread. Even though symptoms are similar circumstances can vary greatly. Not to mention it can be hard to follow multiple conversations within the same thread.

Link to comment
Share on other sites

i would suggest returning it to the place of purchase first. If they are not able to exchange it for you, then i would go ahead and RMA it. But if it's only a couple of hours old that would be the best place to start.

 

If you have any further questions please start your own thread. Even though symptoms are similar circumstances can vary greatly. Not to mention it can be hard to follow multiple conversations within the same thread.

 

Appreciate your reply, called the shop already yesterday and will drop by tomorrow cause they wanted to check it. I'll open a new thread as soon as I hear either from the shop or from Corsair's support (waiting for an email reply still).

 

Thanks again,

 

Nick

 

P.S: yes the PSU is literally a couple of hours "old"

Link to comment
Share on other sites

Hello again,

 

To take it from the start here is my situation.

 

I bought an HX650 PSU last Saturday (3 days ago), came home installed it only to almost immediately getting the infamous chirping or bird-like noise from it (found in other thread s in this forum and also in numerous youtube videos by other users).

After researching about it online I saw it was something already reported by others and I proceeded to open an RMA request with COrsair via the link in this forum but also followed the suggestion by Ram Guy to check with the shop i bought the PSU from since it was literally only a couple of hours "old".

So I did and went by the shop on Monday (yesterday), the tech department asked me to leave the PSU to them so they can check it themselves and try to replicate the problem. Today I dropped by the shop again to check the status (since they said they'd call me yesterday but they didn't...) and the tech gentlemen there replicated the noise problem and confirmed it while i was there.

They promptly replaced the PSU with a brand new identical HX650.

I was worried that it might had the same exact problem with the one i already had bought and asked them if it was from different batches, they replied that they only had PSU's from one batch and couldn't give me one that would be guaranteed not to have the same fault.

 

Anyway, I returned home, installed the PSU on my system an hour ago only to my great disappointment to hear the same exactly noise from the PSU yet again :(::(::(:

 

So here I am seeking help and advise on how I should proceed with this. Especially since the options i have are kinda limited, since the shop will most probably only give me another "singing" PSU and Corsair has not responded to my initial RMA request i started on Saturday :sigh!:

 

Any help Ram Guy ? I must note that I checked with my local post office and the cost (just in case I am asked to return the PSU to Holland is 1/3rd of the retai lprice :[pouts: ) also i must note that I only have this PC so sending it out will mean staying without an operational system for days.

 

In any case I would be extremely greatful for any help on this matter which I would like to have it resolved as soon as possible.

 

Anxiously waiting for your input,

 

Nick

 

P.S: any chance for having a non-faulty replacement sent to me in advance and i sent mine back the minute I receive the replacement ? Or maybe sending the PSU back to the shop i bought it from and getting the replacement from Corsair ?

 

Edit:

 

I just checked my email and it appears my RMA request has been approved by Corsair a couple of hours ago. What course of action would be advisable for me to take now ? Is it possible to have anything arranged as I suggested above ? Would be a shame if I had to pay so much to just ship this 2nd faulty PSU back and also even shipping it for free would suggest I wouldn't have a working system for many days :sigh!:

 

In case it's needed here is my RMA #5494139

Link to comment
Share on other sites

The incorrect part number was on your ticket. I've updated it for you. Please check the ticket for other information.

 

Thanks a lot,

 

Although I am a bit confused on what exact steps i need to take to proceed, so i called earlier Corsair's support tel number and if I am not mistaken (bad line and overseas tel connection, plus that English isn't my 1st language) I was asked to call UPS tomorrow and they should have my details and they'll come pick up my PSU.

 

Please let me know if i got something wrong or there's something I might have misunderstood or overlooked.

 

Thanks again for your help and really appreciate all you gents do supporting us users and of course your products.

 

Regards,

 

Nick

Link to comment
Share on other sites

  • 2 weeks later...

Hello again,

 

I just received a brand new HX650 replacement directly from Corsair this time via the RMA request. Unfortunately this one also does the birdy noise too :o:

 

I'm really frustrated... this is the 3rd PSU in a row that does the exact same annoying noise, add to that that I have been waiting without a PSU for 10 days till the whole RMA completes (PSU to ship back to Holland and the new one to get back to me).

 

I really am lost now, don't know what to do. The shop I bought it originally only has the HX650 and all of them are form the same batch, Corsair was really prompt in their response to replace it the second time via RMA (also covered the costs of shipping both ways) but still the problem is identical yet again.

 

Any ideas on what to do RAM Guy ? Another RMA would mean most probably another birdy singing HX650 I think, not to mention the 10 day period that I'd have once more to wait without a working computer; which to be honest isn't a viable option :[pouts:

 

Help ? :(:

Link to comment
Share on other sites

  • 2 weeks later...

Hello again,

 

This time I just wanted to publicly acknowledge Corsair's EXCELLENT customer support. I am really glad of my choice and despite the problems risen with my original purchased PSU I finally have everything resolved after receiving an HX750.

 

If only more companies had the same customer support and willingness to help like Corsair has done.

 

Big thanks also to the Tech guys here in the forum for their time and help that made things far easier for me even though I'm almost across the planet. Everything went smoothly and as easy as it could have been.

 

Regards,

 

Nick

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...