Jump to content
Corsair Community

H100i Broken already?


ralph9994

Recommended Posts

I've been reading about this online but I dunno what to do.

Long story short:

 

Got a H100i(Last Friday)>Worked perfectly>Updated Firmware>No LED, Fans at 100%>connected the fans to my fancontroller on the 650D>workaround for now but still no LED or Corsair Link recognition.

 

Pump works fine. Fans are working fine. The rest is not.

 

Tried lost of stuff already like plugging in a external usb cable. Reinstalling the Corsair Link Software etc. etc.

 

What do I do now?

Link to comment
Share on other sites

Contact your seller and ask if they can replace it for you. If they won't, request an RMA.

 

If your H100i is working fine. Don't update it.

 

I guess you didn't read this.

NOTE: Please do not do this firmware if you are not having an issue...

Please note that in order to the Firmware update you will need to uninstall the current version and reboot and install Version 2.1.1. to do the Firmware update.

Please make sure to uninstall the older Corsair Link software then reboot the system before installing version 2.2.0

Link to comment
Share on other sites

I guess you didn't read this.

Quote:

Originally Posted by COOL GUY View Post

NOTE: Please do not do this firmware if you are not having an issue...

Please note that in order to the Firmware update you will need to uninstall the current version and reboot and install Version 2.1.1. to do the Firmware update.

Please make sure to uninstall the older Corsair Link software then reboot the system before installing version 2.2.0

 

Toasted, that is one little problem I have discovered. The software just gives you the option to update the FW and downloads the file bypassing the forums. So I'm sure there are many who wont see that note until it's too late.

 

It would be nice if the FW update just directed you to the FWupdate thread so every user is given the opportunity to see the warning.

Link to comment
Share on other sites

Toasted, that is one little problem I have discovered. The software just gives you the option to update the FW and downloads the file bypassing the forums. So I'm sure there are many who wont see that note until it's too late.

 

It would be nice if the FW update just directed you to the FWupdate thread so every user is given the opportunity to see the warning.

 

exactly. It's also placed right next to the CorsairLink software for the H100i product page with no warnings. Someone will install it and be none the wiser--that is until they start having problems and then see the threads. Like I did.

Link to comment
Share on other sites

Toasted, that is one little problem I have discovered. The software just gives you the option to update the FW and downloads the file bypassing the forums. So I'm sure there are many who wont see that note until it's too late.

 

It would be nice if the FW update just directed you to the FWupdate thread so every user is given the opportunity to see the warning.

 

Which version of the dashboard did you use? the "Check for Updates" feature was removed from v2.1.7+. Not sure if the "check for updates" ever worked on v2. But it did on v1.X.X.

Link to comment
Share on other sites

  • Corsair Employees
Toasted, that is one little problem I have discovered. The software just gives you the option to update the FW and downloads the file bypassing the forums. So I'm sure there are many who wont see that note until it's too late.

 

It would be nice if the FW update just directed you to the FWupdate thread so every user is given the opportunity to see the warning.

 

This is something we need to do in the future. Its kinda late now, since 1.04 has been pulled out. We will be more careful in the future and make sure that we direct customer to the right path.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...