Jump to content
Corsair Community

64 GB Flash Voyager USB 3.0 wants to be formated, DATA LOSS ISSUE


Phill

Recommended Posts

Hello, I have Voyager 64gb USB 3.0 flash drive ( CMFVYGZ3S-64GB ) for about 4 months. I am using Windows 7 Enterprise, computer HP EliteBook 6930 with USB 2.0). I did not formatted flash disk to NTFS, there is original FAT-32.

 

Flash drive worked with no problem until couple days ago, then Flash disc started to be recognized as "Removable disk (E:)" several times (approx. five times) but after safe unplug-plug it was recognized normally as 'Corsair' again. Finally the flash disc is recognized only as "Removable disk (E:)" with zero capacity and with message 'You need to format disk in drive E: before you can use it' and then 'The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted'. The same result I have got on another three different PC's.

 

The problem is that I need to get data from flash disc therefore I do not want to format flash disk.

 

Can please someone advise me how to get data from flash drive?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...