Jump to content
Corsair Community

Corsair 500R, fire hazard!


vidfail

Recommended Posts

Just some background info...

Yesterday I was putting together a computer for my brother, and everything was going fine. The case itself was a pleasure to build in, lots of room. First, I tested all the components outside the case to make sure everything worked, and they did.

 

After everything was in the case, and the front I/O connected, pressing the power button produced a billowing cloud of white smoke and a smell of burning rubber. I powered the motherboard in an external build afterward and found nothing wrong with any of the main parts. In fact, the motherboard was posting correctly even as the computer was smoking. However, one of the cables leading from the I/O to it's molex power plug was partially melted.

 

The psu doesn't have a molex connector of course, so I used a molex to 6-pin power cable to connect it to the psu. Oddly, only the cable labelled "2" on the front I/O molex plug was melted, while the cable labelled "1" was completely undamaged.

 

molex_plug.thumb.jpg.ee39d9ffe2641d8a30dd5dcde8fd634c.jpg

back_of_IO.thumb.jpg.7e786c65ff505891cee345469519de1a.jpg

 

Did I plug something in wrong? There was no documentation describing where or how the molex cable should be plugged in, so I assumed directly into the psu. So, is the I/O defective? Or do I need to buy a new one?

 

similar_cable_to_the_one_used_to_connect_io_to_psu.jpg.8b79db311e65052e691ee843acbe1875.jpg

 

Thanks.

cable_used_to_connect_io_to_psu.jpg.6a43ee867fb69a5c910cdd229b4dc160.jpg

Link to comment
Share on other sites

Sorry for the delayed response.

 

And I think I explained this badly... haha. I meant that the PSU doesn't have molex connectors coming from the unit itself (modular). The PSU did come with 6-pin to molex power cables, which is what I used. I guess I uploaded a picture of something entirely different, because I assumed they were all the same...lol Multiple molex plugs leading to a 6-pin psu plug, right?

 

Anyway, we decided to just buy a new front I/O. It's pretty cheap, and I figured it would get here several times faster than any RMA attempt. Hopefully it goes better the second time around...

 

Thanks for your help.

Link to comment
Share on other sites

Seasonic 560W

 

http://www.newegg.com/Product/Product.aspx?Item=N82E16817151098

 

Not an especially cheap PSU I thought. I can't imagine it would "over-volt" something... or whatever a bad PSU does. As I said, everything else in the case turned on fine, and the motherboard was even posting while smoke came out of the case, lol.

 

http://forum.corsair.com/v3/showthread.php?t=111217

 

Looks familiar... :sigh!:

Link to comment
Share on other sites

These guys have valid points over here. You might have accidently (as most modular PSUs have 6 pin for "peripherals+sata" and for "GPU+CPU") inserted the 6-pin into the "GPU+CPU" port when powering that molex to the I/O interface.

 

Its also possible that the I/O was faulty and you did everything right.

Link to comment
Share on other sites

Thanks for all the responses!

 

I'm absolutely sure I plugged the cable into the "Peripherals" section of the PSU. In any case, hopefully we'll receive the new I/O panel by the end of the week. Whatever the result, I'll be sure to report back - good or bad.

Link to comment
Share on other sites

  • 4 weeks later...

We finally got the front I/O. It took awhile, but it turned out it was on back order for a couple weeks. The important part is that it worked, no melting wires or clouds of smoke. I used the same cable, so the old I/O panel had to be faulty.

 

Oh well, my brother's computer is now up and running. Thanks for all your help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...