Jump to content
Corsair Community

H80i not recognizing any fans or devices...


hamBANKER

Recommended Posts

As title....Basically turned on the machine opened Corsair link (ver. 2.2) to find no devices or fans being recognized.

 

Bought the cooler last week, installed and used w/ no issues, able to change speeds adjust profiles etc.

 

Now nothing...tried updating firmware, H80i updates, Corsair Commander "fails to reset" upon using CorsairLinkUSBFW_2.0.6.

 

Tried rearranging USB slots, re jiggering connections, no luck.

 

Would appreciate some insight or ideas?

 

If JPEGS are needed can provide...

Link to comment
Share on other sites

Go into Device Manager. You may see under "Other Devices" - sublink - "Unknown Device". It may have a error shield on the icon. Double click "Unknown Device" and go to the Driver tab. Uninstall driver and reboot your PC. Windows should reload the default Windows driver.

Give that a try

Link to comment
Share on other sites

Mine is doing this as well. Got it working again for a few days then just stops. I just re installed fresh and updated firmware following the guide in the forum but fails after a day or so. Very annoying. May have to sell it and get something more reliable
Link to comment
Share on other sites

  • Corsair Employees
Fully uninstall the software from the control panel, then delete the /program files/corsair/corsair link 2 folder, turn on "show hidden folders" and delete /user/app data/roaming/corsair (if you have our HID or Audio software installed only delete the Corsair Link folders in this sub directory). Unplug the USB header from the MB for about 5min and plug it back in. Restart and clean install of the 2.2.0. Then flash the FW again. http://forum.corsair.com/v3/showthread.php?t=112507
Link to comment
Share on other sites

And if you still have the issue after that have a look here:

 

http://forum.corsair.com/v3/showthread.php?t=113981

 

There is an issue with drivers. Whether the issue is caused by the Windows drivers for the hydro, of another usb device on your system I can't say atm, but making sure the Windows drivers have actually installed is the first step. You can't use CorsairLink or update the firmware until it's properly installed

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...