Jump to content
Corsair Community

m60 dead?


gcediblemedia.

Recommended Posts

I opened the m60 software to adjust the pointer speed, changed the DPI setting and the mouse started refreshing its position like 2 or 3 times a second. I changed usb ports, rebooted and it was still doing it. Also all the buttons had stopped repsonding. I rebooted and it was still doing it.

 

Inserted another mouse, and the slow refresh thing suddenly resolved itself, but all the buttons are still not working. Tried it on my laptop, and same result: pointer moves, none of the buttons do. (Including left right mouseclick)

 

I've requested and RMA, but is it possible its software? I'm using the original version

 

edit: I updated the firmware and its working again but still thats an hour of my life I wont get back.

Link to comment
Share on other sites

This is unfortunately something that happens a lot with this mouse. I've owned it for a year and the same has happened to me over 50 times.

 

Pro-tip: Uninstall the software as soon as you properly configure it. Don't try doing macros, don't try using the profiles system. It won't work and it may "brick" the mouse just like it did before.

Link to comment
Share on other sites

  • Corsair Employees
This is unfortunately something that happens a lot with this mouse. I've owned it for a year and the same has happened to me over 50 times.

 

Pro-tip: Uninstall the software as soon as you properly configure it. Don't try doing macros, don't try using the profiles system. It won't work and it may "brick" the mouse just like it did before.

 

The new firmware solved a lot of the issues. If your mouse has a problem, we can replace it for you and I'll personally test it before sending it out if need be. But please do not derail other's threads unless you have a solution for their problems.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...