Jump to content
Corsair Community

Corsair link connections


Recommended Posts

I currently have an AX1200i power supply and H80i cooler

both these items connect to 2 x usb2 internal male sockets on my motherboard,leaving me with just usb3 internal male sockets.

I have just ordered and am waiting to recieve corsair cooling and light kit

along with corsair accessory cable link kit.

My first question is will the power supply and cooler link to the comander freeing up my usb sockets if so will the kits supplied have the cables to connect to the commander or do they have to be purchased seperately?

i also have an H80 cooler on another rig but no cable is supplied to connect to corsair link. Will there be a cable to connect to corsair link in any kits?


Link to comment
Share on other sites

  • Replies 59
  • Created
  • Last Reply

Yes the AX1200i and H80i can be connected to the Commander Unit freeing up one USB header. (The Commander Unit requires a USB header).


The AXi should have a cable already as there is only one type for it. if the H80i doesn't have a LINK Digital Cable, the Commander unit should have a "long" cable included with the kit. which you can use.


If you have the previous generation H80 cooler on another computer, You can use the Corsair LINK USB Dongle (Included in the AXi PSU) and connect the H80 into it and use the Corsair LINK software.

Link to comment
Share on other sites

Thanks for that imformation much appreciated. another question if you are available to comment.i am also getting a gpu node link to monitor my gtx 690 however i am using the 2 8 pin power connects to power it as its thirsty. does the node also supply power to the graphics card?
Link to comment
Share on other sites



I have an AX760i but I can't see any specific GPU monitoring. Only the readouts from the GPU itself, fan speed and temp.


What I do see under "Power" is this:



And it doesn't make much sense, either (the system should pull more than that even in idle, no?).


I have a Gigabyte GTX 670 OC.

And I used 3rd party cable extensions to connect the GPU. Is that the problem?




Link to comment
Share on other sites



Move the slider below and see if you can find the something names PCIeX ("X" being the port where the GPU PCIe connectors are connected. Once you find it, that is the GPU power monitor.




Press Alt+Print Screen open the system tab to take a screenshot. Then save it in Paint and attach it here.

Link to comment
Share on other sites

Hi Toasted, thanks for pointing out that it should be below that screen.

One thing though: There is no "slider" or scrollbar! I had to pull the window down. But even with 1080 px I can't get it to show everything. I can see the PCIe displays were you can set OCP. But there's no real GPU monitoring – or do I miss something?


Maybe a scrollbar in this screen would be a good idea, instead of having to resize the window. ;)


Here is another screenshot: http://www.abload.de/img/link_powerqpjw0.jpg


So what's the first efficiency/power display and what's the second?


I'm tempted to install the GPU Node just to see if it makes any difference. But then again, I don't want to do all the cable management again and again.

Link to comment
Share on other sites

Please take a screenshot of the device tab under options.


Yes, the OCP box with the PCIe displays is where the GPU power usage is collected from. use a GPU stress tester like Furmark and you should get some readings displayed.


You can install the GPU node to see if it makes a difference. Instead of redoing the cable management, just plug it all in and test it before you do it again.

Link to comment
Share on other sites

got my corsair link cooling and lighting kit today Horay or is it?

removed dongle on power supply ax1200i and plugged it straight into the commander along with the h80i using digital cables supplied. also removing the usb connection from the h80i as mentioned in earlier thread. also connected fan node to commander plugged my silverstone fans into node also connected gpu node.

rebooted no ax1200i h80i or fans registered.

uninstalled software rebooted reinstalled rebooted

still nothing registering except cpu graphics card and drives any suggestions?

commander is plugged into m/b via usb and power cables connected to gpu & fan node

the gpu also has a 2pin black wire whats that for as there are no instructions supplied even though it seems pretty obvious how to connect up.

seems to work better without the commander using the dongle & usb plug on the h80i.

Link to comment
Share on other sites

Thanks toasted will try this approach how ever i would of thought buying dirrect from corsair my firmware would be up to date. As i cant even see the commander i cant check version installed.

does the software display processor graphics cards & hard drives etc without any link equipment just software installed?

Link to comment
Share on other sites

I had the same issue as you and did what Toasted posted. It helped.

It's essential that you follow each step, including the reboot!


You can't see the commander because you have Link 2.2.0? You need to instal 1.2.7 in order to see the commander and update its FW. After that you are unable to see the Commander in 1.2.7, so uninstall 1.2.7, reboot and install 2.2.0 and you will see the commander.


As to the up-to-date firmware: Sometimes parts are stored for a while. It'd be impractical to update every stored item once an update comes out or even when it's shipped out.


@ Toasted:

I don't really see the point in trying a different port. But I think I'll check some other things: GPU node, AX760i alone via usb dongle, ...

Link to comment
Share on other sites

The node just tunnels the two power cords through so the 4 pin power cable would be for the gpu node itself and the 2 pin plug is to connect to a sensor input on the Cooling Node.

As I understand it, in the Dashboard you'd have to click the item and change it from reading temps to Device Type "Power".


Also it was said that if you have an AXi PSU, you don't need the GPU Node.

Link to comment
Share on other sites

I got the node free when buying the link so i thought id give it a try however using it my windows 8 experience index has caused my gpu to lose 0.1 point lol however its the only thing working on the link.....still at work so have to try what toasted suggested when im home. theres alot of things in life you don't need but you still have them.

cheers doublet

Link to comment
Share on other sites

SO i am now up and running i removed 2.2.x installed version 1.2.5(as per yellowbeards thread)i could see my commander plus fan node plus airflowpro- interesting cus i dont have one fitted.

tried to update firmware to i think latest .........but not sure 2.0.6

started to run then locked up so i closed the program using task manager and uninstalled version 1.2.5......no reboot.

proceeded to install version 2.2.0 used the flash firmware there using 2.0.6 haypresto everything worked including my case fans. gpu node still fitted cound'nt be arsed to remove it till i found a solution.

1 thing i have noticed though my ax1200i was running at 99% efficiency now its 90. and my gtx 690 still has 2 fans showing when it only has 1 as far as i can see.:laughing:

now lets see if i can stuff it all up inserting the lighting node.

alt +printscreen dont work for me so i cant show you TOOK A PHOTO INSTEAD LOL


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...