Jump to content
Corsair Community

H100i no corsair LED and not recognized LINK


kidio007

Recommended Posts

Hi, so I just got my H100i and installed it and all was well. I installed 2.2.0 and it had latest firmware. Then I set the fan profile to quiet and temps were good. Then suddently I could hear an usb device beeing disconnected and fans ramped up and corsair logo stopped shining and pump and fans were not recognized in corsair link. Then 10 seconds later I hear a sound like a usb beeing connected, and all was well again. Then this started happening all the time and now it doesnt work 90% of the time. Maybe after 30 minutes USB gets connected again for a few seconds, then disconnected again. Fans are also no good because the vibrate and make a beeeeeeeep noise, so i changed them to 2 noctua fans, and connected them to my PSU. I dont have fan control and corsair logo is not shining, but my temps are good.

 

I have tried all my usb headers, but since the corsair logo is not on, can it still be the usb cable, or is it broken? Any tips on what to do? If I try to flash firmware again it says "H80i/H100i is not connected" I have tried 3 different versions of corsair link.

 

Thanks!

Link to comment
Share on other sites

Does the logo light up when the computer starts?

Try a older version of the dashboard and see if it can detect the H100i

 

When I start my pc the light lights up for 2 seconds, then is gone. If by dashboard you mean corsair link, then I have tried many versions of that yeah.

Could it be the usb cable that is broken? Since I heard usb input beeing dissconnected and reconnected before? If I take out and reconnect the sata cable to the pump, then the light also goes on for 2 seconds, and I hear usb beeing connected sound, then when light goes out I hear usb beeing disconnected sound.

Link to comment
Share on other sites

You can try disconnect the USB cable from the H100i and see if everything is normal but it might be the H100i that is faulty.

If I disconnect the usb cable nothing happens, if I connect it again nothing happens. Light is always off. if I take out the sata cable and hook it back in while the computer is still on the corsair logo lights up for 1 second.

 

If you go into the bios does the light stay on?
No, the light only goes on for 1 second when I turn on the machine. In the bios it is always off.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...