Jump to content
Corsair Community

K60 Pre-boot issues


xSpeced

Recommended Posts

Hi. I bought a k60 yesterday, it works great in windows and bios, but it will not working during the screen part of windows where it allows you to pick "Start Windows Normally" now whenever I get to that screen I have to wait for it to "fix" windows start up and spend 15 mins on reboots.

 

I see there are no fw upgrade for this K60. If I cant find a solution to this, I might have to return the keyboard.

 

My M90 on the other hand works flawless.

Link to comment
Share on other sites

Yes i've tried different usb port, i have a crosshair v formula board.

 

I have a K90 w/firmware v1.0.0.30 and am also unable to use the keyboard in the Windows boot option screen, as well as in GRUB when booting Gentoo Linux (main OS).

 

I too own a Crosshair V Formula. I've flashed BIOS w/the latest v1703 ROM, and have USB Legacy Support enabled (both 2.0 & 3.0). I've tried both 2.0/3.0 USB ports to no avail.

Link to comment
Share on other sites

Thanks - do you have a link to a changelog from ASUS documenting the fix? They stopped offering changelogs through their support site a while back - I haven't found anything so if you could provide this it'd be very helpful. Also, what BIOS version is your Crosshair mobo running?
Link to comment
Share on other sites

Gnarlium, I'll pass this on. Unfortunately in the mean time, I don't have any other options for you since you're already on the latest BIOS which we were told should have resolved this issue.

 

I have the crosshair v and the same problem. Not only cannot I not use it in bios, I also cannot use in the windows boot screen. IE selecting if I want to do a safe boot or normal boot. Cant use with a memtest app. This is ridiculous, I have to plug in a 10yr old ps2 kbd whenever I want to reboot my computer and do anything.

 

Whats up with this Corsair? Did your quality control go on strike and you decided to release this anyways? :biggrin:

Link to comment
Share on other sites

  • Corsair Employees
I have the crosshair v and the same problem. Not only cannot I not use it in bios, I also cannot use in the windows boot screen. IE selecting if I want to do a safe boot or normal boot. Cant use with a memtest app. This is ridiculous, I have to plug in a 10yr old ps2 kbd whenever I want to reboot my computer and do anything.

 

Whats up with this Corsair? Did your quality control go on strike and you decided to release this anyways? :biggrin:

 

Its actually not the keyboard itself, its related to the BIOS. The keyboard works in Windows does it not?

Link to comment
Share on other sites

  • Corsair Employees
The keyboard works fine in Windows and Linux; that's not the issue. It does not work in the Windows boot loader screen, nor in GRUB, nor memtest86+.

 

Its all related to how each of those enumerates the keyboard and is a part of the BIOS on the motherboard. I'll pass it along though for investigation but its puzzling since I have the same board here as a test bench and I have no problems with the K60.

Link to comment
Share on other sites

  • Corsair Employees
Can you please post system specs along with BIOS version for the test bench you're referring to? You say the K60 doesn't have any issues w/this mobo - what about the K90?

 

Crosshair V BIOS 1503

Vengeance 16GB 1866

Force3 120

AX860i

ATI 6850

AMD FX6120

 

The K90 doesn't have this issue. I have passed this along though so we'll go from here.

Link to comment
Share on other sites

Crosshair V BIOS 1503

Vengeance 16GB 1866

Force3 120

AX860i

ATI 6850

AMD FX6120

 

The K90 doesn't have this issue. I have passed this along though so we'll go from here.

 

Thanks for the info. I've experienced the issue on both BIOS v1503 and 1703.

 

A few more questions:

 

Which Crosshair board do you have? The Crosshair V Formula, or the Formula-Z?

 

Which firmware version is installed on the K90?

 

Is USB Legacy Support enabled in BIOS?

Link to comment
Share on other sites

  • 3 months later...

Any update on this issue? I still can't use this keyboard (K90) in the Windows bootloader.

 

ASUS hasn't released any newer BIOS updates since v1703, so I am (still) on the current BIOS version for this board.

 

Have you been able to reproduce this issue since (i.e. with xSpeced's RMA'd K60?)

Link to comment
Share on other sites

  • 1 month later...

Did you ever get a solution to this? I was wondering as I have a K90 and it has never worked in the boot loader or in the bios. I have always had to plug in my Logitech KB to use the bios or pick safe mode.

 

I have MSI P67A-GD65 motherboard.

 

william

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...