Jump to content
Corsair Community

K90 dead (no firmware update)


Azraelrulez

Recommended Posts

Hi, I had bought a K90 from Amazon US on October 6, 2012. My K90 today just up and died. No flashing, no hardware detection (on another PC). tested on 3 working PCs, different ports etc. As far as remember (according to the downloaded folder time stamps), I had flashed 1.19 around 26 Oct 12. I had also faced random issues of the stuck key syndrome once or twice. The keyboard had stopped responding once 2`3 days back but started working when I re-inserted the cables. Now it's totally dead.

 

Now the main issue.

 

I live in India. What are my options for RMA? Will Corsair India fulfill the RMA as the cost is going to be quite high if I have to ship it to the US? Please help out.

 

I don't know if it's going to be any help but I have been a long time user of Corsair products :o: and I hope something can be worked out.

 

Btw, happy new year to every one here :).

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

Ok, my NEW replacement keyboard died today morning. Again. No lights, no flickering, no nothing. No updates, no software/ hardware changes. Shut down my PC fine, booted up after 5~6 hours, keyboard dead. It was on firmware 1.31. Tested on 3 PCs, 2 running Win 7 x64 and 1 on x86.

 

I really don't want to RMA again. Apart from the international shipping costs, last time my replacement kb took almost a month to reach me.

 

Is there anything I can try to revive my keyboard??? Anything???

 

Whatever happens, this is the last time I buy a Corsair accessory. I'll stick to their RAMs and PSUs but no keyboards or mice or headphones. This is so damn frustrating :mad:! Now I'll either have to go back to using my replacement Roccat "sticky keys" Arvo for a month or buy a Logitech mech. This was my 1st mech and it's near impossible to go back to sticky keyboards. Last RMA, my whole productivity and gaming went to hell and I don't think I can bear the same for another month :mad:!

 

Please don't make me RMA!!!! I don't want to whine (I'm 35 :D:) but...this sucks!!!!

Link to comment
Share on other sites

Thanks, Toasted. Have made the call and was asked to submit a new RMA request. I've already done so. I've never had any issues with Corsair support as such and I think the community here (I'm guessing you're not a Corsair employee) is also one of the best.

 

Thanks again for taking the time to help.

Link to comment
Share on other sites

^^Haven't been given one yet. I have submitted a ticket and am waiting for the response. Will edit this post once I receive it or if I don't (just read the last link in your sig).

 

Edit:@Ram Guy below; Replied and done the needful. Will update on next response.

Link to comment
Share on other sites

  • 1 month later...

Got my replacement today. I've connected it to my internal USB headers this time against the normal advice to use the back i/o USB ports in the off chance that maybe those ports killed my kb... twice. Gigabyte does advertise more power in their USB ports, though I've never installed the software that is supposed to enable that. I also have those eSATA/ USB combo ports on my mobo, so I'm wondering if those are a problem too....?

 

Anyways, fingers crossed and thank you Toasted and Ram Guy.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...